WAPT 1.8 - WaptService n'est pas installé

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée ( 1.3.13 / 1.5 / 1.7.4)
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

26 juin 2020 - 17:28

Bonjour,

J'ai un soucis sur quelques postes où j'ai installé wapt agent. Ces postes sont en Windows 10 (Windows update à jour).
L'agent s'installe bien, autant avec waptdeploy par gpo que manuellement. Pourtant dans la console, le statut "joignable" n'est pas disponible. En regardant de plus près je vois que sur ces postes, le service windows waptservice n'est pas présent.
Je n'ai pas trouvé de log d'installation de l'agent pour vérifier s'il y a une erreur. Comment aller plus loin dans mon analyse ?

Merci d'avance.
William
Avatar du membre
sfonteneau
Expert WAPT
Messages : 1152
Enregistré le : 10 juil. 2014 - 23:52
Contact :

29 juin 2020 - 12:21

A mon avis c'est un antivirus qui passe par là ...
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

30 juin 2020 - 10:47

Bonjour,

J'ai effectivement pensé à ça. Pourtant j'ai bien toutes les exclusions que j'ai pu trouver sur un autre post renseignées dans notre antivirus. Windows defender est lui désactivé.

Je viens de m'apercevoir que sur ces 9 postes, une version de python est installée (2.5.2150). Est-ce que ca peut générer un conflit avec wapt 1.8.1?
Je précise la version de wapt car j'ai 1 poste qui lui est en 1.7.4 alors qu'il a aussi une version de python 2.5.2150 et que je n'ai pas de soucis avec...

edit : Je retire ce que j'ai dit dans la dernière phrase puisque l'agent wapt a été installé avant l'applicatif qui m'installe python 2.5.2.
edit2 : Je confirme que c'est bien le fait qu'il y est python 2.5.2 d'installé sur le poste qui cause ce problème (testé avec une nouvelle installation de poste), mais comment m'en sortir ?
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

30 juin 2020 - 15:18

Je viens de trouver la cause de mon problème : J'ai une variable d'environnement système "PYTHONPATH" qui pointe vers un répertoire applicatif métier.
Si je l'édite et que je remplace le chemin par celui de l'installation WAPT ou encore si je la supprime : en réinstallant waptagent, le service s'installe bien.
J'ai tenté d'ajouter le chemin de l'installation de mon wapt afin de ne pas avoir à supprimer les autres chemins, mais le service ne s'installe pas. (ex : PYTHONPATH = C:\wapt;C:\S3_exec)

Je vais voir du coté de l'éditeur de logiciel métier si la variable est vraiment nécessaire.
Si quelqu'un à une autre idée ?
Avatar du membre
sfonteneau
Expert WAPT
Messages : 1152
Enregistré le : 10 juil. 2014 - 23:52
Contact :

30 juin 2020 - 16:15

On avait des soucis en 1.8.1 avec ça mais en 1.8.2 ça a l'air mieux, pouvez-vous essayer avec la 1.8.2 ?
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

01 juil. 2020 - 11:30

sfonteneau a écrit :
30 juin 2020 - 16:15
On avait des soucis en 1.8.1 avec ça mais en 1.8.2 ça a l'air mieux, pouvez-vous essayer avec la 1.8.2 ?
Bonjour,

Merci pour votre retour.
Je viens de passer en 1.8.2.7267 coté serveur et client mais le problème reste le même.

Cordialement
William
Avatar du membre
sfonteneau
Expert WAPT
Messages : 1152
Enregistré le : 10 juil. 2014 - 23:52
Contact :

01 juil. 2020 - 11:36

Pouvez vous renommer waptguihelper.pyd en waptguihelper.pyd.old

Le problème viens souvent de waptguihelper.pyd

Vous pouvez chercher dans le dossier d'installation wapt waptguihelper.pyd (il peu être a deux endroit)
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

01 juil. 2020 - 11:59

sfonteneau a écrit :
01 juil. 2020 - 11:36
Pouvez vous renommer waptguihelper.pyd en waptguihelper.pyd.old

Le problème viens souvent de waptguihelper.pyd

Vous pouvez chercher dans le dossier d'installation wapt waptguihelper.pyd (il peu être a deux endroit)
Je n'ai pas compris où vous vouliez que je modifie le fichier. Dans le dossier du poste client où est installé wapt ? Si oui ensuite comment je relance l'installation du service ?
Avatar du membre
sfonteneau
Expert WAPT
Messages : 1152
Enregistré le : 10 juil. 2014 - 23:52
Contact :

01 juil. 2020 - 12:21

Il faut juste chercher waptguihelper.pyd et renomer le fichier en waptguihelper.pyd.old

puis lancer un redémarrage du service

Code : Tout sélectionner

net stop waptservice
net start waptservice
William12
Messages : 10
Enregistré le : 03 juin 2020 - 16:57

01 juil. 2020 - 12:28

sfonteneau a écrit :
01 juil. 2020 - 12:21
Il faut juste chercher waptguihelper.pyd et renomer le fichier en waptguihelper.pyd.old

puis lancer un redémarrage du service

Code : Tout sélectionner

net stop waptservice
net start waptservice

Comme je l'ai dit dans mes précédents messages, le soucis c'est que le service windows "waptservice" ne s'installe pas à cause de la variable "PYTHONPATH". Du coup je ne peux le redémarrer puisqu'il n'existe pas.
Répondre