Contactez nous

[RESOLU] Mise à jour de l'agent sous un serveur 2003/samba3

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour.
En cas !
Pour les personnes qui sont encore sous un serveur 2003 ou sur un serveur Samba 3 (si si c'est possible ;-)), les comptes utilisateurs n'ont en principe pas le droit d'installer des logiciels.
Suite à la mise à jour en 1.5 j'utilise l'utilitaire cpau : http://www.joeware.net/freetools/tools/cpau/index.htm
Ci-dessous le script qui teste la version sur un fichier texte et lance un "job" crypté afin de ne pas afficher les identifiants :

Code : Tout sélectionner

echo off
WMIC DATAFILE WHERE name="c:\\wapt\\wapt-get.exe" get Version /format:Textvaluelist > c:\versionwapt.txt
find "Version=1.5.1.18" c:\versionwapt.txt
if %errorlevel% equ 1 goto pasbon
goto end
:pasbon
echo off
"\\serveur\netlogon\cpau.exe" -dec -file "\\192.168.1.254\serveur\zwapt.job" -lwp
echo off
:end
Pour créer le job :

Code : Tout sélectionner

 - cpau -u domain\user -p pass -ex "\\serveur\netlogon\waptagent" \verysilent -enc -file "\\serveur\netlogon\zwapt.job"
Bonjour,

Même si elle est documentée sur Internet, c'est une très mauvaise pratique pour déployer WAPT.

Considérez plutôt migrer vers Windows Server 2012+ et/ou Samba4, ce sera plus sain pour tout le monde

Cordialement,

Alexandre
Bonjour Raphaël,

merci Raphaël pour ta contribution au forum, mais je ne peux pas m'empêcher de réagir à ton post, car je vois trop souvent cette erreur commise.
raphael a écrit :
29 mars 2018, 15:37
Pour les personnes qui sont encore sous un serveur 2003 ou sur un serveur Samba 3 (si si c'est possible ;-)), les comptes utilisateurs n'ont en principe pas le droit d'installer des logiciels.
Suite à la mise à jour en 1.5 j'utilise l'utilitaire cpau : http://www.joeware.net/freetools/tools/cpau/index.htm
Ci-dessous le script qui teste la version sur un fichier texte et lance un "job" crypté afin de ne pas afficher les identifiants :
IL NE FAUT ABSOLUMENT PAS UTILISER CPAU.EXE POUR VOS DÉPLOIEMENTS!!!!!

Il est très simple de récupérer le mot de passe d'un fichier .job CPAU. Si vous ne me croyez pas, essayez un coup avec l'utilitaire API Monitor [1]. Vous pouvez vous inspirer de la page https://micksmix.wordpress.com/2013/03/ ... -software/

En 2 minutes top chrono on récupère le mot de passe administrateur de vos postes (téléchargement des outils compris)... Si vous n'arrivez pas à suivre le tuto juste au dessus (il y un détail qui n'est pas bien expliqué, histoire de rendre le niveau de la chose un tout petit peu au dessus du script kiddie), vous pouvez m'envoyer votre fichier job CPAU, je vous renverrai votre mot de passe...

Et de toute façon, si on doit en arriver à utiliser du CPAU, probablement que l'IPC$ et l'ADMIN$ sont aussi ouvert, et un PSExec fera mieux l'affaire (même si c'est vraiment pas recommandé du tout). Il y a aussi certain anti-virus qui ont des fonctionnalité basique de déploiement. Et puis (pour détendre l'atmosphère), tant qu'on y est, vérifiez s'il n'est pas aussi possible d'utiliser la faille EternalBlue, il y a des fois où ça peut aider :-) .

Bonne soirée à tous,

Denis

PS : pour les utilisateurs de win2k3, le déploiement par GPO marche très bien!

[1] http://www.rohitab.com/apimonitor