Génération de l'agent impossible (erreur ssl)

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
Grég5689
Messages : 2
Inscription : 11 juin 2018 - 16:17

11 juin 2018 - 16:23

Bonjour,

Suite à l'installation du serveur Wapt 1.5 je tente de créer un agent via la console. Tout se déroule bien lors de la compilation jusqu'à ce que l'on me demande la clé. J'entre celle-ci correctement, la compilation reprend et une boite de dialogue s'ouvre avec une erreur à laquelle je ne trouve pas de solution.

Erreur : An unhandled exception has occured
Création impossible du paquet de mise à jour WAPT
ConnectionError: ("bad handshake: Error("bad handshake: Error(['SSL routines', 'ssl3_get_record', 'wrong version number')],)",)

J'ai testé l’accès à l'adresse https://localhost:443 et cela fonctionne.

Le serveur est installé sur une machine virtuelle clean. Nous travaillions avant avec la version 1.3 sans le moindre problème.
Dans l'attente d'une éventuelle solution,

Merci.
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 784
Inscription : 10 juil. 2014 - 23:52
Contact :

12 juin 2018 - 08:46

Avez-vous activé la vérification https?
Grég5689
Messages : 2
Inscription : 11 juin 2018 - 16:17

12 juin 2018 - 09:27

Non je ne l'ai pas activé justement.... je ne comprends pas.
cap1.JPG
cap1.JPG (61.44 Kio) Consulté 1249 fois

Informations : le serveur est installé dans un établissement scolaire. Nous utilisons l'interface Kwartz, j'ai donc ouvert certain port afin de laisser un accès à WAPT. Cependant avec la version 1.3 cela fonctionnait, Il y a peut être des choses à modifier avec la nouvelle version...
AlbanUCA
Messages : 7
Inscription : 28 mai 2018 - 12:21

26 nov. 2018 - 16:00

Bonjour,

Avez-vous trouvé une solution ?
Nous sommes en train de valider la solution en production malheureusement, suite à la création de nos différentes clés, nous avons se message d'erreur lors de la création de l'agent.

Alban
AlbanUCA
Messages : 7
Inscription : 28 mai 2018 - 12:21

26 nov. 2018 - 17:03

Salut,

Nous avions le même problème pour la création d'un agent.
J'ai désactivé le proxy pour l'accès au serveur Wapt.
L'agent s'est créé directement .

J'espère que cette piste est bonne.

Alban
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 784
Inscription : 10 juil. 2014 - 23:52
Contact :

26 nov. 2018 - 17:49

Très franchement je n'ai pas eu l'occasion de tester wapt avec kwartz.

En général nous conseillons d'installer wapt sur "un serveur réservé uniquement à cet usage"

https://www.wapt.fr/fr/doc/wapt_server_ ... quirements
Il me semble que qwartz écoute sur l'interface 443.
Répondre