Page 1 sur 1

[RESOLU]Deploiment WaptAgent GPO windows 7

Publié : 19 juin 2018 - 17:18
par skoizer
Bonjour

Je rencontre un probléme pour le deploiement de l'agent via GPO
J'ai bien mis une GPO machine et j'entend bien que le reseau soit up pour lancer les GPO.
Via la commande ci dessous en admin local ou admin du domaine cela fonctionne, l'agent wapt s'installe

waptdeploy.exe --hash=maHache --minversion=1.5.1.23 --wait=15 use_fqdn_as_uuid=1 --waptsetupurl=https://srvwapt01/wapt/waptagent.exe
Mais rien en GPO sauf sous Windows 10 cette gpo n'a pas de soucis.
Windows 10 et Windows 7 ont les même GPO dans mon active directory
Pour simuler l'instal sous windows 7 et win10, j'ai testé d'installer avec psexec

voir doc https://specopssoft.com/blog/how-to-bec ... th-psexec/
"autorite nt\système"
voici ce que j'ai comme erreur

Code : Tout sélectionner

c:\tmp>waptdeploy.exe --hash=maHache
acae2f7ab4c78 --minversion=1.5.1.23 --wait=15 use_fqdn_as_uuid=1 --waptsetupurl=
https://srvwapt01/wapt/waptagent.exe
WAPT version:
WAPT required version: 1.5.1.23
Wapt agent path: C:\Windows\TEMP\waptagent.exe
Wget new waptagent from https://srvwapt01/wapt/waptagent.exe
Trying to reach https://srvwapt01/wapt/waptagent.exe...
Reachable, downloading...
Done.
Cleanup...
Unable to update immediately: Unable to download: http://127.0.0.1:8088/update.json?notify_server=1&notify_user=0 HTTP Status: 0
An unhandled exception occurred at $00416608:
EFOpenError: Unable to open file "C:\Windows\TEMP\waptagent.exe"
  $00416608
  $004164B0
  $00440216
  $004047C9
avec windows 10 avec qui cela fonctionne

Code : Tout sélectionner

waptdeploy.exe --hash=maHache
acae2f7ab4c78 --minversion=1.5.1.23 --wait=15 use_fqdn_as_uuid=1 --waptsetupurl=
https://srvwapt01/wapt/waptagent.exe
WAPT version:
WAPT required version: 1.5.1.23
Wapt agent path: C:\windows\TEMP\waptagent.exe
Wget new waptagent from https://srvwapt01/wapt/waptagent.exe
Trying to reach https://srvwapt01/wapt/waptagent.exe...
Reachable, downloading...
Done.
SHA256 hash of downloaded setup file: 6f8d08eb448042eb1562063b93299093cec484e98936fcfbb3dacae2f7ab4c78
OK : Hash of waptagent match expected hash.
Got version: 1.5.1.23
Unable to speak with waptservice... continue (Unable to download: http://127.0.0.1:8088/tasks.json HTTP Status: 0)

Install ...
Launching C:\windows\TEMP\waptagent.exe /VERYSILENT /MERGETASKS=""useWaptServer""
Install OK : 1.5.1.23
Cleanup...
quelqu'un aurait il une idée de probléme sur l'instal.
systéme n'aurait pas les bons droits ?
j'ai comparé les droit de C:\Windows\TEMP sous win10 et win7 et c'est la même chose

Re: Deploiment WaptAgent GPO windows 7

Publié : 20 juin 2018 - 09:55
par skoizer
Bonjour,
J'ai essayé d'installer le waptagent.exe avec le compte "autorite nt\système" cela fonctionne.
Donc c'est un probléme sur watdeploy.exe.
Dommage qu'il n'y est pas une commande pour avoir plus de log.
Y a t'il des bug connu sous W7 et waptdeploy ?

Re: Deploiment WaptAgent GPO windows 7

Publié : 23 juin 2018 - 01:05
par dcardon
Bonsoir Skoizer,
skoizer a écrit :
20 juin 2018 - 09:55
Bonjour,
J'ai essayé d'installer le waptagent.exe avec le compte "autorite nt\système" cela fonctionne.
Donc c'est un probléme sur watdeploy.exe.
Dommage qu'il n'y est pas une commande pour avoir plus de log.
Y a t'il des bug connu sous W7 et waptdeploy ?
Est ce que vous pourriez vérifier si ce n'est pas votre antivirus qui supprime le fichier avant qu'il puisse être installé?

Cordialement,

Denis

Re: Deploiment WaptAgent GPO windows 7

Publié : 08 févr. 2019 - 13:47
par verdierr
bonjour,

Désolé de reprendre ce topic mais je suis pratiquement dans la même situation

Suite à l'installation de wapt 1.6.2.7 pour remplacer wapt1.3.12.13

J'ai créé une GPO qui fonctionne correctement si je ne mets pas "use_fqdn_as_uuid=1" mais nous souhaitons conserver le fqdn

Pouvez vous me confirmer qu'il est possible de le passer en arguments de waptdeploy et si oui, merci de m'indiquer la commande détaillée

Cordialement

Re: Deploiment WaptAgent GPO windows 7

Publié : 13 févr. 2019 - 11:41
par dcardon
Bonjour verdierr,
verdierr a écrit :
08 févr. 2019 - 13:47
Désolé de reprendre ce topic mais je suis pratiquement dans la même situation

Suite à l'installation de wapt 1.6.2.7 pour remplacer wapt1.3.12.13

J'ai créé une GPO qui fonctionne correctement si je ne mets pas "use_fqdn_as_uuid=1" mais nous souhaitons conserver le fqdn

Pouvez vous me confirmer qu'il est possible de le passer en arguments de waptdeploy et si oui, merci de m'indiquer la commande détaillée
Je vous conseille de partir sur la version 1.7, il est possible de configurer ce paramètre directement lors de la création de l'agent.

Cordialement,

Denis

Re: Deploiment WaptAgent GPO windows 7

Publié : 13 févr. 2019 - 14:14
par verdierr
Bonjour,

Merci, je viens d'installer la version 1.7.3.3
La case à cocher lors de la création de l'agent est exactement ce que nous souhaitions

Bonne journée

Re: Deploiment WaptAgent GPO windows 7

Publié : 06 mars 2019 - 12:19
par james
Bonjour,
j'ai exactement le même problème à savoir que suite à la mise à jour en version 1.6.2, le waptdeploy ne fonctionne pas du tout sur les w7 alors qu'en W10 tout est ok. J'ai récupéré la dernière version du waptdeploy mais même problème. L'antivirus n'est pas en cause car désactivé pour les tests.
J'ai testé également dans la GPO de rajouter le paramètre --waptsetupurl= (en http et pas https), et de mettre en --force. Même Problème. Est-ce que la version 1.7 corrige ce problème ? J'aimerais éviter d'avoir à faire la maj dans un premier temps. Est-ce conseillé du coup de passer la gpo avec le waptagent directement et non pas le waptdeploy ?
Merci


Meme code d'erreur que le collègue pour win7 :
c:\tmp>waptdeploy.exe --hash=maHache
acae2f7ab4c78 --minversion=1.5.1.23 --wait=15 use_fqdn_as_uuid=1 --waptsetupurl=
https://srvwapt01/wapt/waptagent.exe
WAPT version:
WAPT required version: 1.5.1.23
Wapt agent path: C:\Windows\TEMP\waptagent.exe
Wget new waptagent from https://srvwapt01/wapt/waptagent.exe
Trying to reach https://srvwapt01/wapt/waptagent.exe...
Reachable, downloading...
Done.
Cleanup...
Unable to update immediately: Unable to download: http://127.0.0.1:8088/update.json?notif ... ify_user=0 HTTP Status: 0
An unhandled exception occurred at $00416608:
EFOpenError: Unable to open file "C:\Windows\TEMP\waptagent.exe"
$00416608
$004164B0
$00440216
$004047C9