Impossible d'installer des logiciels

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
qi-support
Messages : 6
Inscription : 29 août 2016 - 16:15

24 oct. 2018 - 16:18

Bonjour,

Je rencontre un soucis à l'utilisation de Wapt. Lorsque je souhaite déployer des applications, dans mon cas c'est assez basique, il s'agit de Firefox j'ai ce message :

Installing QI-firefox
AttributeError: 'NoneType' object has no attribute 'package'
Traceback (most recent call last):
File "C:\wapt\waptservice\waptservice.py", line 2031, in run
self.running_task.run()
File "C:\wapt\waptservice\waptservice.py", line 1291, in pwrapper
return func(*arg, **kwargs)
File "C:\wapt\waptservice\waptservice.py", line 1351, in run
self._run()
File "C:\wapt\waptservice\waptservice.py", line 1775, in _run
','.join([ p[1].package for p in self.result['errors']]),
AttributeError: 'NoneType' object has no attribute 'package'

Le paquet vient du store wapt standard.

Avez-vous une idée du problème ?

ALN
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 335
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

24 oct. 2018 - 17:35

Bonjour ALN,
qi-support a écrit :
24 oct. 2018 - 16:18
Je rencontre un soucis à l'utilisation de Wapt. Lorsque je souhaite déployer des applications, dans mon cas c'est assez basique, il s'agit de Firefox j'ai ce message :

Installing QI-firefox
AttributeError: 'NoneType' object has no attribute 'package'
Traceback (most recent call last):
File "C:\wapt\waptservice\waptservice.py", line 2031, in run
self.running_task.run()
File "C:\wapt\waptservice\waptservice.py", line 1291, in pwrapper
return func(*arg, **kwargs)
File "C:\wapt\waptservice\waptservice.py", line 1351, in run
self._run()
File "C:\wapt\waptservice\waptservice.py", line 1775, in _run
','.join([ p[1].package for p in self.result['errors']]),
AttributeError: 'NoneType' object has no attribute 'package'
Est ce que vous pourriez préciser votre environnement, cf. viewtopic.php?f=9&t=886

A tout hasard, est ce que vous pourriez essayer avec un préfixe de paquet en minuscule au lieu de l'avoir en majuscule. Ca ne devrait pas faire de différence, mais bon, on ne sait jamais, il y a peut être un bug à ce niveau là.

De plus pour avoir plus de log, il faudrait lancer la commande suivante dans un cmd.exe avec les droits admin (attention à l'UAC)
wapt-get install -l debug qi-firefox

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
qi-support
Messages : 6
Inscription : 29 août 2016 - 16:15

24 oct. 2018 - 18:02

Ok merci de votre retour.

Voici mon environnement :
- Version de WAPT : 1.3.5
- OS server : Windows server 2008 R2
- OS Client : Windows 7 pro 64 bits

J'ai modifié le préfixe en minuscule.

Voici le résultat de la commande : https://i.imgur.com/oNVKPS3.jpg

Merci de votre aide.

ALN.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 335
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

25 oct. 2018 - 19:59

Bonjour ALN,

qi-support a écrit :
24 oct. 2018 - 18:02
Voici mon environnement :
- Version de WAPT : 1.3.5
- OS server : Windows server 2008 R2
- OS Client : Windows 7 pro 64 bits

J'ai modifié le préfixe en minuscule.

Voici le résultat de la commande : https://i.imgur.com/oNVKPS3.jpg
note : il est préférable de faire copier coller du code de cmd.exe avec les balises phpbb (cf. la basice </> au dessus de la textbox d'édition). Ca permet d'avoir le contexte directement dans le thread du post.

Le message d'erreur dit qu'il n'arrive pas à trouver le fichier en question sur le serveur web. Pour convertir le préfixe en minuscule, il faut le changer dans votre console WAPT et puis ré-uploder le paquet. En effet le nom du paquet apparait aussi dans le fichier de control et dans l'indexe Packages.

Cordialement,

Denis

PS : il faut prévoir d'upgrader votre version de serveur WAPT. A partir du mois prochain, les paquets du store ne seront plus forcément compatible avec la version 1.3.
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
qi-support
Messages : 6
Inscription : 29 août 2016 - 16:15

26 oct. 2018 - 12:24

Bonjour,

Effectivement, la modification du préfixe n'a pas était prise en compte, c'est bon maintenant pour ce point.

J'ai supprimé tous les paquets de mon dépôt privé, et télécharger mon firefox-esr. Il est maintenat bien préfixé en minuscule. Par contre, j'ai toujours le même message lorsque je souhaite installer ce paquet. Voici le résultat de la commande lancé depuis le PC client : https://i.imgur.com/2DE7X7R.jpg

Merci de votre aide.

ALN
qi-support
Messages : 6
Inscription : 29 août 2016 - 16:15

26 oct. 2018 - 16:59

J'ai redémarré le serveur, et depuis c'est le drame :)

Le service Windows WAPTMongodb est en pause. Du coup, plus d'accès à l'inventaire du parc.

Que me conseillez-vous ?
Supprimer toutes traces de WAPT sur le serveur et repartir de 0 ?
Comment réagissent les PCs clients lorsque je vais réinstaller le client par dessus l'ancien ?

ALN
qi-support
Messages : 6
Inscription : 29 août 2016 - 16:15

26 nov. 2018 - 16:34

Bonjour,

Je suis reparti de 0.

C'est ok maintenant avec la dernière version.

ALN
Répondre