PC clonés avec Fog

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
gaelds
Messages : 189
Inscription : 22 nov. 2015 - 08:37

14 sept. 2020 - 16:55

Bonjour,
J'ai refais les images de toute une salle de PC windows 10 avec mon serveur Fog. Et désormais, seul le dernier PC sur lequel j'ai lancé un wapt-get register s'affiche dans la console. Quel est la procédure pour que wapt reconnaisse correctement tous les PC après clonage ? J'utilise wapt 1.8.2, serveur Debian.
jprcrna
Messages : 1
Inscription : 12 oct. 2020 - 15:51

12 oct. 2020 - 16:12

Bonjour,
Normalement pour cloner on fait un sysprep pour que chaque poste soit unique
Ou alors c'est un problème de CM qui donne le même numéro, y a une commande pour le régénérer : wapt-get generate-uuid
j'avais eu ca sur des tout en un msi
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 556
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

15 oct. 2020 - 14:50

Bonjour Gaelds,
gaelds a écrit : 14 sept. 2020 - 16:55 Bonjour,
J'ai refais les images de toute une salle de PC windows 10 avec mon serveur Fog. Et désormais, seul le dernier PC sur lequel j'ai lancé un wapt-get register s'affiche dans la console. Quel est la procédure pour que wapt reconnaisse correctement tous les PC après clonage ? J'utilise wapt 1.8.2, serveur Debian.
comme l'a mentionné jpcrna le problème vient de clone "parfait". L'identifiant unique utilisé par défaut est le UUID BIOS, qui est sensé être unique. Certain constructeur peuvent livrer par erreur, ou manque de rigueur, des machines avec des UUID identiques. Dans ce cas là il faut le forcer avec la commande generate-uuid, ou bien se baser sur le FQDN machine comme identifiant unique, cf. la doc.
Cordialement,
Denis Cardon
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
gaelds
Messages : 189
Inscription : 22 nov. 2015 - 08:37

30 oct. 2020 - 08:11

Merci pour la réponse ! Effectivement sur cette salle les PC sont réapparus dans la console après un generate-uuid.
Répondre