[RESOLU] Problème Pyscripter 4 et moteur python

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

17 mai 2021 - 14:05

Bonjour,

Depuis la mise à jour de pyscripter en v4, il ne trouve plus le chemin de python dans le dossier d'installation de wapt. Voir capture ci-dessous :

Image

Auriez-vous une idée à me suggérer ?

Merci
Dernière modification par olaplanche le 19 mai 2021 - 14:15, modifié 1 fois.
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

17 mai 2021 - 14:45

pyscripter 32 bit ? (wapt est 32bit donc il a besoin de pyscripter 32 pas le 64)
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

17 mai 2021 - 15:43

oui version 4.0.0.5 x86, j'ai utilisé le paquet pyscripter du store wapt.
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

17 mai 2021 - 15:55

Le paquet a un soucis il installe la version x64 :roll:
Je regarde ça
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

17 mai 2021 - 15:59

ah ça me rassure :mrgreen:

J'attends ton retour pour faire la mise à jour.

Merci
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
Avatar de l’utilisateur
jpele
Messages : 77
Inscription : 04 mars 2019 - 12:01
Localisation : Nantes

17 mai 2021 - 18:13

Bonjour,
J'ai testé de nouveau sur plusieurs environnement et le paquet PyScripter s'installe bien en x86.
Pouvez-vous supprimer complètement PyScripter et l'installer depuis le paquet puis re-tester.

Cordialement,
Jimmy
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

18 mai 2021 - 11:29

Bonjour,

Idem après réinstallation de la v4, idem après réinstallation de la v3 (et suppression de la V4 de mon store local).
La v4 n'est plus disponible sur le store wapt, je ne peux pas réinstaller la v4 depuis le store du coup.

Merci
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

19 mai 2021 - 14:14

ok je viens de résoudre mon problème !

Après analyse du paquet pyscripter v3 (la v4 est "cassée") disponible sur le store, il semble que les modifications apportées au fichier pyscripter.local.ini ne soient pas prise en compte lors de l'installation (tout du moins chez moi).

J'ai recopié les modifications concernant la version de python suivantes à la fin du fichier pyscripter.local.ini du profil administrateur local de ma machine :

Code : Tout sélectionner

[PythonVersions-x86]
InstallPath=C:\Program Files (x86)\wapt

[PythonVersions-x86\Custom Versions]
Path0=C:\Program Files (x86)\wapt
Count=0
Après cette modification, pyscripter fonctionne à nouveau comme il se doit (je viens de mettre à jour un paquet)
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
olaplanche
Messages : 114
Inscription : 26 janv. 2017 - 11:11

19 mai 2021 - 14:23

Après utilisation de pyscripter le fichier pyscripter.local.ini à changé comme ci-dessous :

Code : Tout sélectionner

[PythonVersions-x86\Custom Versions]
Path0=Python 2.7 (32bit)=C:\Program Files (x86)\wapt
Count=1

[PythonVersions-x86]
InstallPath=C:\Program Files (x86)\wapt
- Version de WAPT installée : 1.8.2.7357 Enterprise
- OS du serveur : Linux / Debian Buster
- OS de la machine d'administration/création des paquets : Windows 10
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

20 mai 2021 - 09:47

En faite c'est tout simple

pyscripter4 n'est plus compatible python 2.7

Il faudra donc attendre la discorvery pour utiliser pyscripter4
Répondre