Contactez nous

Samba 4.8.4, pb de dépendances

Venez ici partager vos astuces et aides autour de Samba4
Bonjour,
Lorsque j'essaie de mettre a jour les rpms 4.7.7 vers votre 4.8.4 du 20 aout, j'ai des dependances non resolues:

Error: Package: pytalloc-2.1.13-1.el7.centos.x86_64 (installed)
Requires: libtalloc = 2.1.13-1.el7.centos
Removing: libtalloc-2.1.13-1.el7.centos.x86_64 (installed)
libtalloc = 2.1.13-1.el7.centos
Updated By: libtalloc-2.1.14-2.el7.x86_64 (krynn_samba_rhel7)
libtalloc = 2.1.14-2.el7
Available: libtalloc-2.0.8-4.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.0.8-4.el7
Available: libtalloc-2.1.1-1.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.1.1-1.el7
Available: libtalloc-2.1.2-1.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.1.2-1.el7
Available: libtalloc-2.1.5-1.el7_2.i686 (rhel-7-server-rpms)
libtalloc = 2.1.5-1.el7_2
Available: libtalloc-2.1.6-1.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.1.6-1.el7
Available: libtalloc-2.1.9-1.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.1.9-1.el7
Available: libtalloc-2.1.10-1.el7.i686 (rhel-7-server-rpms)
libtalloc = 2.1.10-1.el7
Error: Package: python2-samba-4.8.4-0.0.el7.x86_64 (krynn_samba_rhel7)
Requires: python2-dns
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report

Les rpms pytalloc et pytalloc-devel ne semblent plus disponibles dans la version 4.8.4
Bon cela a fini par marcher.
Pour reference:
1) yum install de pyton2-dns depuis EPEL.
2) rpm -e pytalloc pytalloc-devel --nodeps
3) rpm -Fvh x86_64/*.rpm noarch/*.rpm

Je suis maintenant en 4.8.4. Merci TranquilIT! :)