[RESOLU] Déplacement du dossier wua et store sur le serveur

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
olm
Messages : 2
Inscription : 02 févr. 2021 - 10:48

09 juin 2021 - 16:20

Version de WAPT Enterprise installé : 1.8.2.7334 sur serveur Debian Buster

Bonjour,

Nous rencontrons un petit problème pour déplacer le dossier wapt_wua et wapt_folder sur une autre partition

voici ce que nous avons effectuer

1) déplacement des dossier de /var/www/wapt et /var/www/waptwua dans le dossier /wapt ce qui donne une arborescence :
pour wua : /wapt/waptwua
pour le dépot principal de wapt : /wapt/wapt
nous avons bien repris les même droits d'accès

2) changement dans le fichier de config du serveur wapt avec ajout/modifications des deux lignes suivante :
wapt_folder = /wapt/wapt
waptwua_folder = /wapt/waptwua

après redémarrage du service quand nous relançons la console, l'url du dépot principal indique une erreur 502 bad gateway

en fouillant un peu nous avons réussi à trouver le problème, nous devions aussi modifier le fichier de configuration nginx.

après un nouveau redémarrage, l'erreur 502 bad gateway à changer de ligne sur l'url du serveur wapt

je pense que nous touchons au but, mais nous somme encore coincé, auriez-vous un idée de la marche à suivre

merci d'avance
Olivier MARCOUX
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 656
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

15 juin 2021 - 11:27

Si vous avez juste besoin de faire un autre point de montage vous pouvez essayer de faire un mount --bind plutôt que de changer tous les paramètres
mount --bind /wapt/wapt/ /var/www/wapt/
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
corrieamato
Messages : 1
Inscription : 29 juil. 2021 - 13:32

29 juil. 2021 - 13:53

Merci pour ce post qui m'eclaire un peu!
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 656
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

30 juil. 2021 - 17:29

merci pour le retour :-)
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
Répondre