Contactez nous

Problème de déploiement de paquet wapt 1.5

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour à tous,
Depuis la mise du serveur wapt en 1.5.1.21 sur un serveur 2008 R2, je rencontre des difficultés pour déployer des paquets wapt.

J'ai l'erreur suivante :

Code : Tout sélectionner

"C:\wapt\lib\site-packages\urllib3\connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings InsecureRequestWarning)".
Dans les préférences :
Pour le chemin vers le bundle de CA, j'ai fais "récupération certificatserveur" qui va chercher automatiquement le certificat dans :

Code : Tout sélectionner

c:\users\nom_profil\appdata\roaming\waptconsole\ssl\server\nom_du_certificat.crt
=> pourquoi ce chemin ?

Et pour le chemin du certifiact personnel j'ai c:\private\nom_du_certificat.crt

Sinon j'ai un package avec des chiffres (sections host) qui essaye de s'installer !

Cdt,
Elminio
Bonjour,

Il faut distinguer deux choses :
  • Le certificat SSL/TLS du serveur web nginx qui permet de fiabiliser et sécuriser la connexion entre l'agent et le serveur
  • Le certificat Code-Signing qui permet de vérifier l'authenticité des paquets déployés par l'agent WAPT
Votre premier problème concerne le certificat SSL/TLS du serveur qui est sûrement le certificat autosigné généré lors de la post-configuration de l'agent.

Si vous souhaitez utiliser un certificat SSL/TLS valide, merci de suivre la procédure décrite dans la documentation : https://www.wapt.fr/fr/doc/Installation ... ec-windows

Sinon j'ai un package avec des chiffres (sections host) qui essaye de s'installer !
C'est dans la doc : https://www.wapt.fr/fr/doc/waptserver_u ... d-du-poste

Alexandre
Pour mon premier problème, j'ai désactivé la vérification du certificat https serveur et supprimer le chemin vers le bundle de CA.
Pour mon second problème qui est vraiment bloquant, tous les paquets sont signé et j'ai suivi la doc lors de la migration.
j'ai une exception pour l'ensemble des paquets à l'installation ou la mise à jour.
Elminio.
La commande pour resigner les paquet et pour la migration des machine a t'elle été exécuter dans un cmd administrateur ?
La commande a bien été appliquer en tant qu'admin.
Mes groupes et mes paquets sont bien signé avec le même certificat personnel.
J'installe manuellement l'agent wapt sur un poste je lance l'installation d'un paquet et je me retrouve avec une exception.

Elminio.
Pouvez-vous indiquer l'exception ?
Exception : Erreur lors de l'installation
et dans debug j'ai ceci :

Code : Tout sélectionner

Installing deploiement-ultravnc
Installing deploiement-plugin_net
Installing 1-bureautique
Installing 4C4C4544-0051-5810-8036-C6C04F353332
Exception: Erreur lors de l'installation de 4C4C4544-0051-5810-8036-C6C04F353332 (=15): erreurs dans les paquets [[u'deploiement-ultravnc', PackageEntry('deploiement-ultravnc','1.2.1.2-1') ], [u'deploiement-plugin_net', PackageEntry('deploiement-plugin_net','1.2-0') ], [u'1-bureautique', PackageEntry('1-bureautique','28') ], [u'4C4C4544-0051-5810-8036-C6C04F353332 (=15)', PackageEntry('4C4C4544-0051-5810-8036-C6C04F353332','15') ]]
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptservice\waptservice.py", line 1151, in run
    self.running_task.run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 405, in pwrapper
    return func(*arg, **kwargs)
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 464, in run
    self._run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 884, in _run
    self.result.get('errors',[])))
Exception: Erreur lors de l'installation de 4C4C4544-0051-5810-8036-C6C04F353332 (=15): erreurs dans les paquets [[u'deploiement-ultravnc', PackageEntry('deploiement-ultravnc','1.2.1.2-1') ], [u'deploiement-plugin_net', PackageEntry('deploiement-plugin_net','1.2-0') ], [u'1-bureautique', PackageEntry('1-bureautique','28') ], [u'4C4C4544-0051-5810-8036-C6C04F353332 (=15)', PackageEntry('4C4C4544-0051-5810-8036-C6C04F353332','15') ]]
si vous avez installé les agents à la main vérifiez le wapt-get.ini des clients. Le mien n'avait pas les bons paramètres surtout le verify_cert
il a fallut déployer un wapt-get.ini fonctionnel sur les postes et les redémarrer
j'ai procédé à une réinstallation complète du serveur et j'ai ce message :
root:ERROR for C:\private\wapt-private.pem: Unable to load key C:\private\wapt-private.pem
lorsque je veux déployer un paquet en mode debug.
beemoon,

voici la config de wapt-get.ini sur les postes :

[global]
repo_url=https://serveur.wapt/wapt
send_usage_report=1
use_hostpackages=1
wapt_server=https://serveur.wapt
use_kerberos=0
check_certificates_validity=1
verify_cert=0
dnsdomain=
max_gpo_script_wait=180
pre_shutdown_timeout=180
hiberboot_enabled=0
[wapt-templates]
repo_url=https://store.wapt.fr/wapt
verify_cert=1