Contactez nous

Probleme SSL sur repo secondaire

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,

Serveur : Debian 9 / WAPT 1.5.1.21
Machine de dev / Windows 10

J'ai créé un repo secondaire, mais quand j'essaie d'installer un paquet sur ma machine de dev à partir de ce repo, j'ai des erreurs SSL. J'imagine que je dois importer le certificat, mais je ne sais pas où le trouver, ni où le placer ensuite.
Je n'ai rien vu à ce sujet dans la doc : https://www.wapt.fr/fr/doc/Replicate_Mu ... index.html

Si quelqu'un peut m'expliquer...
Merci d'avance
E.T.

P.S. aux admins : j'ai posé cette question dans la partie "paquets WAPT" du forum (avec d'autres questions, d'ailleurs). Après reflexion, je me suis dit que le lieu était peut être plus approprié ici... mais pas moyen de déplacer le message.
Bonjour

Pour bien comprendre:

https://www.wapt.fr/fr/doc/Configuratio ... at-ssl-tls


Vous avez plusieurs solution, vous pouvez générer une ca pour la vérification du certificat https il vous suffira ensuite d'ajouter la CA comme chemin pour verify_cert

Autre solution, vous pouvez créer un fichier allcert.crt que vous placez dans ssl\server\

Ce fichier contiendra tous les certificats des différents repo. Ce qui permettra une vérification correcte.

Sinon enclenchez un

Code : Tout sélectionner

wapt-get enable-check-certificate
sur les clients
Bonjour,

Merci pour votre réponse.
La doc que vous me signalez, et la commande wapt-get enable-check-certificate permettent de récupérer le certificat du serveur. Je n'ai aucun probleme avec ce certificat.
Le probleme est avec celui du repo secondaire (seul tis-waptrepo est installé sur ce serveur).
Re,

Bon, en fait, je viens de faire un test de recup d'un paquet à partir d'un navigateur web. Ca a un peu éclairé ma lanterne (pourquoi n'y ai je pas pensé avant ?).
J'ai effectivement un probleme de certificat, mais pas celui que je pensais :
The certificate is not trusted because it is self-signed.
The certificate is only valid for ancien-hostname

Le certificat créé n'a pas le bon hostname ("ancien-hostname" dans les lignes ci-dessus). Cette machine est un serveur virtuel, déployé à partir d'un template, et le certificat a pris le nom du template, pas celui de la machine (que j'ai pourtant modifié avant d'installer tout le reste).

Bref, est ce que vous auriez une idée de comment je peux regénérer un certificat https sur cette machine ?
Merci d'avance
E.T.