Contactez nous

Pb d'upload setup crée et impor d'application de paquet

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,

J'ai fait l'installation de wapt sur debian comme indiqué sur votre site, la aucun problème
j'installe la console sur le pc et crée le certificat,
quand je crée l'agent il me demande bien la passphrase, puis juste après il m'indique cela

Code : Tout sélectionner

[Window Title]
waptconsole

[Content]
Création impossible du paquet de mise à jour WAPT
HTTPError: 500 Server Error: INTERNAL SERVER ERROR for url: https://wapt.Mondom/api/v3/upload_packages

[OK]
Je l'upload donc avec scp

puis quand je vais sur les depot pour importé 7zip j'ai de nouveau le message

Code : Tout sélectionner

[Window Title]
waptconsole

[Content]
Unable to import package : HTTPError: 500 Server Error: INTERNAL SERVER ERROR for url: https://wapt.Mondom/api/v3/upload_packages

[OK]
Je ne pense pas avoir fait d'erreur lors de l'installation, on dirait que le serveur interdit les connexion et pourtant je n'ai pas activé le firewall sur le serveur et sur Windows j'ai réessayé après avoir désactivé le firewall mais rien ne change

Vous n'auriez pas une idée s'il vous plait

Merci
Apparement c'est un problème avec python

Code : Tout sélectionner

Jul  3 16:12:10 wapt python[6259]: [2018-07-03 16:12:10,851] ERROR in app: Exception on /api/v3/upload_packages [POST]
Jul  3 16:12:10 wapt python[6259]: Traceback (most recent call last):
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/lib/python2.7/site-packages/flask/app.py", line 1982, in wsgi_app
Jul  3 16:12:10 wapt python[6259]:     response = self.full_dispatch_request()
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/lib/python2.7/site-packages/flask/app.py", line 1614, in full_dispatch_request
Jul  3 16:12:10 wapt python[6259]:     rv = self.handle_user_exception(e)
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/lib/python2.7/site-packages/flask/app.py", line 1517, in handle_user_exception
Jul  3 16:12:10 wapt python[6259]:     reraise(exc_type, exc_value, tb)
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/lib/python2.7/site-packages/flask/app.py", line 1612, in full_dispatch_request
Jul  3 16:12:10 wapt python[6259]:     rv = self.dispatch_request()
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/lib/python2.7/site-packages/flask/app.py", line 1598, in dispatch_request
Jul  3 16:12:10 wapt python[6259]:     return self.view_functions[rule.endpoint](**req.view_args)
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/waptserver/waptserver.py", line 199, in decorated
Jul  3 16:12:10 wapt python[6259]:     if not check_auth(auth.username, auth.password):
Jul  3 16:12:10 wapt python[6259]:   File "/opt/wapt/waptserver/waptserver.py", line 225, in check_auth
Jul  3 16:12:10 wapt python[6259]:     password.encode('utf8')).hexdigest()
Jul  3 16:12:10 wapt python[6259]: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 27: ordinal not in range(128)
J'ai modifier le mot de passe de l'admin avec des lettre simple et cela fonctionne, c'est donc la conversion de caractère qui merdouile, comment puis-je rectifier cela s'il vous plait

j'ai un autre message suite à cela :

[Window Title]
waptconsole

[Content]
Erreur lors du chargement de l'agent WAPT vers le dépôt : inattendu : ((<type 'exceptions.IOError'>, IOError(13, 'Permission denied'), <traceback object at 0x7fe99afb0830>),)

[OK]

Cela vous parle t-il ?

Merci
Du coup j'ai modifier le mot de passe de connexion à la console du coup le premier message à disparue et j'ai réussi à ré-uploader le fichier, donc pour ceux qui aurait le problème cela vient de votre mot de passe qui contient des caractère spéciaux style éè etc donc attention

Peut être que cela pourrait être corrigé sur une version future ?

Merci
Bonjour Yoyox,
yoyox a écrit :
04 juillet 2018, 11:52
Du coup j'ai modifier le mot de passe de connexion à la console du coup le premier message à disparue et j'ai réussi à ré-uploader le fichier, donc pour ceux qui aurait le problème cela vient de votre mot de passe qui contient des caractère spéciaux style éè etc donc attention

Peut être que cela pourrait être corrigé sur une version future ?
en effet, il faut corriger cela.
yoyox a écrit :
04 juillet 2018, 11:52

Merci
C'est sur quelle version de WAPT?

Merci,

Denis