[RESOLU] Erreur lors du déploiement par GPO

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
Zirconium95
Messages : 2
Inscription : 21 sept. 2018 - 12:08

21 sept. 2018 - 12:13

Bonjour,

J'essaie de déployer WAPT via GPO avec un script de démarrage, voici les paramètres :
waptdeploy.exe --hash=*(le hash)* --minversion=1.5.1.26 --waptsetupurl=https://(nom du serveur wapt)/wapt/waptagent.exe --force --wait=30

et j’obtiens ça comme erreur :

WAPT version:
WAPT required version: force
Wapt agent path: E:\TEMP\waptagent.exe
Wget new waptagent from https://(nom du serveur wapt)/wapt/waptagent.exe
Trying to reach https://(nom du serveur wapt)/wapt/waptagent.exe...
Reachable, downloading...
Done.
Cleanup...
Unable to update immediately: Unable to download: http://127.0.0.1:8088/update.json?notif ... ify_user=0 HTTP Status: 0
An unhandled exception occurred at $00416608:
EFOpenError: Unable to open file "E:\TEMP\waptagent.exe"
$00416608
$004164B0
$00440216
$004047C9

le plus étrange c'est que quand je lance la commande depuis la session utilisateur cela fonctionne.

merci.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 280
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

21 sept. 2018 - 18:48

Bonjour Zirconium95,
Zirconium95 a écrit :
21 sept. 2018 - 12:13
J'essaie de déployer WAPT via GPO avec un script de démarrage, voici les paramètres :
waptdeploy.exe --hash=*(le hash)* --minversion=1.5.1.26 --waptsetupurl=https://(nom du serveur wapt)/wapt/waptagent.exe --force --wait=30

et j’obtiens ça comme erreur :

WAPT version:
WAPT required version: force
Wapt agent path: E:\TEMP\waptagent.exe
Wget new waptagent from https://(nom du serveur wapt)/wapt/waptagent.exe
Trying to reach https://(nom du serveur wapt)/wapt/waptagent.exe...
Reachable, downloading...
Done.
Cleanup...
Unable to update immediately: Unable to download: http://127.0.0.1:8088/update.json?notif ... ify_user=0 HTTP Status: 0
An unhandled exception occurred at $00416608:
EFOpenError: Unable to open file "E:\TEMP\waptagent.exe"
$00416608
$004164B0
$00440216
$004047C9

le plus étrange c'est que quand je lance la commande depuis la session utilisateur cela fonctionne.
L'erreur vient du fait que waptdeploy ne peut pas trouver le fichier waptagent.exe après l'avoir téléchargé. Trois possibilité:
* votre antivirus l'a supprimé avant l'installation
* le répertoire E:\temp est un partage SMB et le serveur gère les exe d'une manière spécifique
* waptdeploy.exe a un bug
Mais bon, pour aller un peu plus loin ça manque cruellement d'information...

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le wiki WAPT
Zirconium95
Messages : 2
Inscription : 21 sept. 2018 - 12:08

24 sept. 2018 - 13:58

Bonjour,

Merci pour votre réponse, j'ai réussis à trouvé une "parade", je pousse en premier le waptagent.exe par la GPO et ensuite exécute le scripte et tout fonctionne.

Merci pour votre aide.
Répondre