Contactez nous

register machine hors AD avec kerberos d'activé

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,
comment enregistrer une machine hors AD avec kerberos d'activé ?
Merci
Mettre dans l'agent en question :

Code : Tout sélectionner

use_kerberos = 0
Le serveur devrait demander l'identifiant / Mot de passe du serveur wapt
Désolé mais cela ne fonctionne pas ..

Je viens d'effectuer quelques tests :

machine pc1 - W7 - machine hors domaine

waptserver.ini : conf de base
allow_unauthentificated_connect = False
allow_unauthentificated_registration = True
use_kerberos = True

https://www.wapt.fr/fr/doc/Configuratio ... index.html :
allow_unauthenticated_registration = True Permet une authentification Identifiant / Mot de passe pour l’enregistrement initial
allow_unauthenticated_connect = False Définit si les requêtes websocket doivent être authentifiées

test 1 :

waptserver.ini :
allow_unauthentificated_connect = False
allow_unauthentificated_registration = True
use_kerberos = True

wapt-get.ini
use_kerberos = 1

wapt-get register
Waptservice User : compte admin local
> erreur WaptBadServerAuthentification ce qui est normal !

test 2 :

waptserver.ini :
allow_unauthentificated_connect = False
allow_unauthentificated_registration = True
use_kerberos = True

wapt-get.ini
use_kerberos = 0

wapt-get register
Waptservice User : compte admin local
> L'inventaire est envoyé au serveur WAPT .. il y a donc un binz côté serveur qui accepte les machines sans connexion avec compte admin WAPT

test 3 :

waptserver.ini :
allow_unauthentificated_connect = False
allow_unauthentificated_registration = False
use_kerberos = True

wapt-get.ini
use_kerberos = 0

wapt-get register
Waptservice User : compte admin local
> erreur WaptBadServerAuthentification

test 4 :

waptserver.ini :
allow_unauthentificated_connect = True
allow_unauthentificated_registration = False
use_kerberos = True

wapt-get.ini
use_kerberos = 0

wapt-get register
Waptservice User : compte admin local
> erreur WaptBadServerAuthentification
Dans tous les cas il faut laisser

Code : Tout sélectionner

allow_unauthentificated_connect = False

Il n'interviens pas dans l'enregistrement et en terme de sécurité c'est mieux qu'il soit a False

Test2 c'est normal que ça fonctionne vous avez mis

Code : Tout sélectionner

allow_unauthentificated_registration = True
Donc forcément le serveur accepte

Test3 et Test4 devrait fonctionner. Je viens de tester il fonctionne chez moi WAPT 1.6 mais vous passez visiblement par le service local, il vous faut exécuter la commande

Code : Tout sélectionner

wapt-get register
Dans un cmd exécuté en administrateur
Bon effectivement le wapt-get register dans un cmd exécuté en administrateur demande bien le compte admin wapt et ça fonctionne ! C'est parfait, merci beaucoup !!