Mise à jour debian : nginx directive auth_gss inconnue

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
jdieu
Messages : 3
Inscription : 14 déc. 2018 - 11:24

14 déc. 2018 - 11:32

Bonjour,

Version de WAPT installée : 1.6
- OS du serveur : Debian 9.6

Suite à une mise à jour de debian, nginx est passé en version 1.10.3.

Le service ne veut plus démarrer, il ne reconnait pas la directive auth_gss dans le fichier de conf :
/etc/nginx/sites-enabled/wapt.conf

Pour l'instant, j'ai commenté :
# location /add_host_kerberos {
# auth_gss on;
# auth_gss_keytab /etc/nginx/http-krb5.keytab;
# proxy_pass http://127.0.0.1:8080;
#}

Comment cela peut etre corrigé ?
jdieu
Messages : 3
Inscription : 14 déc. 2018 - 11:24

14 déc. 2018 - 12:01

le module /usr/lib/nginx/modules/ngx_http_auth_spnego_module.so avait été supprimé

le fichier /etc/nginx/modules-enabled/50-mod-http-auth-spnego.conf existait mais était vide.

J'ai remis le tout en état, décommenté les lignes du fichier de conf et redémarré nginx, tout est correct.

Si ça peut servir à quelqu'un ...

Bye!
TomTomGo
Messages : 17
Inscription : 03 mai 2017 - 15:36
Localisation : La Chapelle sur Erdre

17 déc. 2018 - 10:03

Bonjour,

J'ai le même souci et en allant voir dans le fichier https://wapt.tranquil.it/debian/wapt-1. ... _amd64.deb je me rends compte que le module est absent du package (/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so)
Comment as-tu résolu le problème ?

Merci
jdieu
Messages : 3
Inscription : 14 déc. 2018 - 11:24

19 déc. 2018 - 13:08

Bonjour,

je l'ai récupéré d'un backup.

Cordialement,
james
Messages : 21
Inscription : 18 sept. 2018 - 16:37

21 déc. 2018 - 16:17

Bonjour,
j'ai exactement le même problème ...
Répondre