[RESOLU]V 1.6.2.7 Connexion sur la console via AD impossible

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 839
Inscription : 10 juil. 2014 - 23:52
Contact :

19 déc. 2018 - 12:41

Le port 389 fonctionne maintenant ?

Vérification avec :

Code : Tout sélectionner

telnet srv00.xxxx.local 389
Si non faire la modification indiqué dans mot post précédent plus haut (dans le fichier /opt/wapt/waptenterprise/waptserver/auth_module_ad.py)
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

19 déc. 2018 - 12:44

Bonjour,

Comme indiqué, la console remonte certaines informations de l'AD (mais l'authentification ne passe pas).

Pour la commande : telnet srv00.xxxx.local 389

Voici le résultat :
Trying 192.168.1.200...
Connected to srv00.xxxx.local.
Escape character is '^]'.

Connection closed by foreign host.
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 839
Inscription : 10 juil. 2014 - 23:52
Contact :

19 déc. 2018 - 13:16

Les OU remontées dans la console sont remontées par les postes (pas de connexion ad),

Si vous voyez les OU dans la console cela ne signifie pas que la connexion ldap fonctionne.

Le port 389 semble maintenant dispo, vous n'avez donc pas besoin de faire la modification. Votre configuration semble correcte.
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

19 déc. 2018 - 13:35

Bonjour,

Pourtant lorsque j'utilise mes informations de connexion AD pour tenter d'ouvrir la console avec mon compte du domaine, l'authentification ne passe pas.

Mon compte est bien dans le groupe AD Waptadmins qui est bien dans la bonne OU (comme indiqué dans le fichier ini)

Je ne comprends pas ce qui peux bloquer
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

20 déc. 2018 - 09:01

Y a t'il un système permettant de tester la connexion WAPT / AD avec des logs ?
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 839
Inscription : 10 juil. 2014 - 23:52
Contact :

20 déc. 2018 - 10:53

Bonjour

Pour lancer le serveur en mode debug :

Code : Tout sélectionner

systemctl stop waptserver
/opt/wapt/runwaptserver.sh -ldebug
Le serveur est alors démarré en mode debug (laissez votre putty ouvert)

Vous devriez voir passer l'authentification

Pouvez-vous nous fournir le fichier /opt/wapt/conf/waptserver.ini (en masquant les informations sensibles wapt_password ,secret_key )
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

20 déc. 2018 - 11:07

Je viens de tester le débug, j'ai ce résultat :
2018-12-20 11:06:41,414 DEBUG Traceback (most recent call last):
File "/opt/wapt/waptserver/server.py", line 927, in login
raise EWaptAuthenticationFailure('Authentication failed.')
EWaptAuthenticationFailure: Authentication failed.
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

21 déc. 2018 - 07:59

Auriez vous une idée sur ce blocage?
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 839
Inscription : 10 juil. 2014 - 23:52
Contact :

21 déc. 2018 - 09:16

guil.cap a écrit :
21 déc. 2018 - 07:59
Auriez vous une idée sur ce blocage?
Le log ne parle pas de la partie ldap

Pouvez-vous nous fournir le fichier /opt/wapt/conf/waptserver.ini (en masquant les informations sensibles wapt_password ,secret_key )
guil.cap
Messages : 13
Inscription : 18 déc. 2018 - 11:05

21 déc. 2018 - 12:01

Le voici :
[options]
waptwua_folder = /var/www/waptwua
server_uuid = a480287a-a79c-11e8-ac90-fe149ee36605
wapt_password = XXXXXXXXXXXXXXXXXXx
allow_unauthenticated_registration = True
secret_key = XXXXXXXXXXXXXXXX
use_kerberos = True
allow_unauthenticated_connect = True
wapt_admin_group_dn = CN=waptadmins,OU=Groupes,DC=xxxx,DC=local
ldap_auth_server = srv00.xxxx.local
ldap_auth_base_dn = DC=xxxx,DC=local
ldap_auth_ssl_enabled = False
Répondre