[RESOLU] Ubuntu 21.04

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
thomas789
Messages : 24
Inscription : 31 mai 2021 - 15:44

27 juil. 2021 - 16:17

Bonjour, pourriez-vous nous donner des informations au sujet de la compatibilité WAPT pour les agents installés sur des postes fonctionnant sous Ubuntu 21.04 ? Merci d'avance, cordialement.

(agents des postes Windows/Ubuntu en 2.0.0 / version WAPT Enterprise sur serveur Debian Buster / admin console sur Windows 10)
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 680
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

27 juil. 2021 - 16:35

Bonjour Thomas,
la version 2.0 utilise le python système et les librairies compilées (pyopenssl, etc.) nécessite les ABI correspondantes. On ne supporte donc que les version LTS en version 2.0.

A partir de la version 2.1 on embarque le python dans l'agent WAPT (version 3.8.11, pour être justement moins dépendant des variations du système). Vous pouvez tester une nightly 2.1 sur une ubuntu 21.04 pour voir : https://srvwapt-pro.tranquil.it/entrepr ... -amd64.deb (mdp idem que pour le dépôt deb)

Je suis intéressé du retour.

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
thomas789
Messages : 24
Inscription : 31 mai 2021 - 15:44

07 oct. 2021 - 14:36

Bonjour,

Nous avons pu tester ce .deb (https://srvwapt-pro.tranquil.it/entrepr ... -amd64.deb), plutôt que celui ci dessus, (prérequis libffi 7 demandé), sur un poste en Ubuntu 21.04. L'installation OK et le poste remonte bien sur le console mais dès que l'on essai d'installer un de nos paquets, le poste reste en UPGRADE et aucun paquet ne s'affiche pour ce poste. Pour information, notre serveur est en 2.1.

Merci d'avance,

Cordialement.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 680
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

14 oct. 2021 - 14:47

Bonjour Thomas,

si le poste remonte bien dans la console avec la websocket, c'est que le service fonctionne correctement. Donc le python 3.8 recompilé est ok sur une ubuntu 21.04.

Il faudrait lancer un wapt-get update / upgrade pour voir si il voit bien le paquet que vous lui avez affecté. Si il ne le voit pas, il faudrait vérifier si les différents paramètres de filtrage sont correctes (type d'os, version d'os, langue, x86 vs x64, etc.)

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
thomas789
Messages : 24
Inscription : 31 mai 2021 - 15:44

20 oct. 2021 - 16:38

Bonjour,

Merci pour ce retour. Ticket résolu. Cela provenait du certificat n’ayant pas été ajouté sur le poste (ajout du privatewaptkey.crt dans /opt/wapt/ssl et wapt-get register).

Cordialement, Thomas.
Répondre