upgrade 2.0.0.9450

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
fck_mly
Messages : 15
Inscription : 01 sept. 2020 - 16:28

16 août 2021 - 12:27

Bonjour,

Suite à la diffusion concernant la faille et l'upgrade à la version 2.0.0.9450, je rencontre un message d'erreur lorsque je lance l'upgrade :

Code : Tout sélectionner

The following packages will be upgraded:
  aspell krb5-locales krb5-user libaspell15 libgssapi-krb5-2 libgssrpc4 libk5crypto3 libkadm5clnt-mit11 libkadm5srv-mit11 libkdb5-9 libkrb5-3 libkrb5support0
  libnss-systemd libpam-systemd libsystemd0 libudev1 linux-image-4.19.0-17-amd64 systemd systemd-sysv tis-waptserver tis-waptsetup udev
22 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/131 MB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Fatal Python error: initfsencoding: Unable to get the locale encoding
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f22ac063740 (most recent call first):
Aborted
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -lt 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10
En regardant un peu, j'ai vu que j'avais python 2.7 et python 3.7 dans /usr/local/lib.
Dois-je "désinstaller" python 2.7 ?
Auriez-vous une piste pour régler ce message d'erreur ?

En vous remerciant par avance.
WAPT Server : 2.1 Entreprise
WAPT Agent : 2.1.0.10534
OS du serveur : Debian 10 (buster)
Machines admin/clientes : Win10 x64
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

16 août 2021 - 15:28

Code : Tout sélectionner

python3
Python 3.7.3 (default, Jan 22 2021, 20:04:44) 
>>> import locale
>>> locale.getpreferredencoding()
'UTF-8'
>>> 
Pouvez-vous tenter ceci sur votre machine pour voir si getpreferredencoding fonctionne ?
fck_mly
Messages : 15
Inscription : 01 sept. 2020 - 16:28

16 août 2021 - 15:38

Merci pour votre réponse.
Par contre, je ne peux absolument pas lancer python3...

Code : Tout sélectionner

root@****wapt:/opt/wapt/bin# python3
Fatal Python error: initfsencoding: Unable to get the locale encoding
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f62b4542740 (most recent call first):
Aborted
WAPT Server : 2.1 Entreprise
WAPT Agent : 2.1.0.10534
OS du serveur : Debian 10 (buster)
Machines admin/clientes : Win10 x64
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

16 août 2021 - 16:45

avec ceci ça fonctionne ? :

Code : Tout sélectionner

/usr/bin/python3.7
fck_mly
Messages : 15
Inscription : 01 sept. 2020 - 16:28

16 août 2021 - 16:51

Non, toujours la même erreur...
Nous n'avons pas eu de souci lors de la migration de la 1.8 à la 2.0.
WAPT Server : 2.1 Entreprise
WAPT Agent : 2.1.0.10534
OS du serveur : Debian 10 (buster)
Machines admin/clientes : Win10 x64
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1208
Inscription : 10 juil. 2014 - 23:52
Contact :

16 août 2021 - 17:37

Wapt ne touche pas a python, nous utilisons un virtualenv c'est donc étonnant :

là c'est le python local de votre machine qui ne fonctionne plus:

dans votre export avez-vous des référence a python ?

Code : Tout sélectionner

export|grep -i python
https://openclassrooms.com/forum/sujet/erreur-dencoding
fck_mly
Messages : 15
Inscription : 01 sept. 2020 - 16:28

17 août 2021 - 12:21

Bonjour,
Merci pour le tuyau.
Après avoir fait des mauvaises manips, avoir restauré la VM hébergée, désinstaller Python puis réinstaller, l'upgrade a fonctionné même si j'ai toujours la même erreur python...
Quoi qu'il en soit, la migration vers la version 9450 est OK.

Bonne journée.
WAPT Server : 2.1 Entreprise
WAPT Agent : 2.1.0.10534
OS du serveur : Debian 10 (buster)
Machines admin/clientes : Win10 x64
Répondre