[RESOLU] Debian 11 - Update

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
elelay
Messages : 27
Inscription : 20 oct. 2020 - 12:39

18 août 2021 - 14:47

Bonjour,

J'ai essayé de mettre à jour mon serveur wapt de Debian 10 à Debian 11 mais après mise à jour, le service waptserver ne fonctionnait plus.

Les journaux me disent qu'il manque des modules python, et pourtant ils sont bien installés.
En fouillant un peu plus j'ai vu ceci dans le code de /opt/wapt/bin/pip qui m'intriguait :

Code : Tout sélectionner

#!/opt/buildbot/basedir/wapt-build-debian-10-packages/build/waptserver/deb/builddir/opt/wapt/bin/python
J'ai essayé de le modifier pour qu'il vise le bon exécutable. En vain.

J'ai aussi essayé de réinstaller pip dans le répertoire de wapt pour installer les modules manquants, mais je me retrouve bloqué pour certains.

Suis-je le seul à avoir eu ce souci ? Aurais-je raté une procédure quelconque ? Faut-il attendre avant de faire la màj ?

PS : J'ai effectué la màj vers la version Entreprise 2.0.9450 avant évidemment et je suis revenu en Debian 10 grâce à un snapshot.

Cordialement,

Étienne
Dernière modification par elelay le 18 août 2021 - 16:53, modifié 1 fois.
Version de WAPT Server : 2.0 Entreprise
Console installée sur un Windows Server 2019
Serveur Debian 10 Buster
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1209
Inscription : 10 juil. 2014 - 23:52
Contact :

18 août 2021 - 16:42

Bonjour

Vous être trop rapide, waptserver n'est pas encore compatible debian11, nous n'avons pas encore préparer les paquets.

Simon
elelay
Messages : 27
Inscription : 20 oct. 2020 - 12:39

18 août 2021 - 16:52

Bonjour Simon,

Merci pour la réponse !
C'est bien ce qui me semblait aussi ;) Au temps pour moi.
Version de WAPT Server : 2.0 Entreprise
Console installée sur un Windows Server 2019
Serveur Debian 10 Buster
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 680
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

01 sept. 2021 - 11:01

On a mis en ligne la version deb11 du serveur et de l'agent : https://srvwapt-pro.tranquil.it/entrepr ... _amd64.deb
Cordialement,
Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
Répondre