Arrêts intempestifs WaptServer sur Débian

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
*Afin de faciliter l'aide dans ce forum, merci de préciser dans vos posts les éléments suivants :
- Version de WAPT installée (1.3.9 / 1.3.13 / 1.5 / 1.6)
- OS du serveur (Linux / Windows)
- OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.
Fabien LAMAISON
Messages : 5
Inscription : 21 mars 2017 - 09:11

21 mars 2017 - 09:33

Bonjour à tous,

Je test depuis une petite semaine Wapt via une VM Debian fraichement installée pour l'occasion. Tout fonctionne très bien mais le serveur Wapt s'arrête de manière intempestive et je suis obligé de le relancer via /etc/init.d/waptserver restart (ou start).
J'ai regardé dans le fichier de log je n'ai pas grand chose comme information. Je vous mets le LOG en fin de post, j'ai eu à redémarrer le service à 7h35 puis à 8h11. Parfois tout va fonctionner pour la journée et s'arrêter le soir. Parfois je vais avoir à redémarrer le service 3 fois dans la journée (quand je me rends compte qu'il ne tourne plus, je ne suis pas tout le temps dessus). J'ai regardé du coté de la mise en veille et ai bien désactivé. J'ai redémarrer plusieurs fois la VM pour vérifier mais sans changement, le service démarre bien avec la machine puis s'arrête après quelques temps.

J'avoue avoir des connaissances assez limitées sous Linux pour savoir dénicher la cause de l'arrêt de processus, est ce que quelqu'un a une idée de où il faut regarder?

En complément d'information, la VM dispose de 2 coeurs, 1Go de ram et 80Go de DD, je pense que c'est suffisant pour assurer la distribution sur les 30-35 postes clients (actuellement seulement 15 postes connectés)?

Merci d'avance pour votre aide.

Code : Tout sélectionner

*** Starting uWSGI 2.0.7-debian (64bit) on [Tue Mar 21 07:35:06 2017] ***
compiled with version: 4.9.1 on 25 October 2014 19:17:54
os: Linux-3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07)
nodename: serveur-wapt
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 2
current working directory: /
writing pidfile to /var/run/waptserver.pid
detected binary path: /usr/bin/uwsgi-core
setgid() to 33
setuid() to 117
your processes number limit is 3908
your memory page size is 4096 bytes
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to TCP address 127.0.0.1:8080 fd 3
Python version: 2.7.9 (default, Jun 29 2016, 13:11:10)  [GCC 4.9.2]
Python main interpreter initialized at 0xb4e6d0
python threads support enabled
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 1237056 bytes (1208 KB) for 16 cores
*** Operational MODE: preforking ***
WSGI app 0 (mountpoint='') ready in 3 seconds on interpreter 0xb4e6d0 pid: 21354 (default app)
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 21354)
spawned uWSGI worker 1 (pid: 21379, cores: 1)
spawned uWSGI worker 2 (pid: 21380, cores: 1)
spawned uWSGI worker 3 (pid: 21381, cores: 1)
spawned uWSGI worker 4 (pid: 21382, cores: 1)
spawned uWSGI worker 5 (pid: 21383, cores: 1)
spawned uWSGI worker 6 (pid: 21384, cores: 1)
spawned uWSGI worker 7 (pid: 21385, cores: 1)
spawned uWSGI worker 8 (pid: 21386, cores: 1)
spawned uWSGI worker 9 (pid: 21387, cores: 1)
spawned uWSGI worker 10 (pid: 21388, cores: 1)
spawned uWSGI worker 11 (pid: 21389, cores: 1)
spawned uWSGI worker 12 (pid: 21390, cores: 1)
spawned uWSGI worker 13 (pid: 21391, cores: 1)
spawned uWSGI worker 14 (pid: 21392, cores: 1)
spawned uWSGI worker 15 (pid: 21393, cores: 1)
spawned uWSGI worker 16 (pid: 21394, cores: 1)
*** Starting uWSGI 2.0.7-debian (64bit) on [Tue Mar 21 08:11:00 2017] ***
compiled with version: 4.9.1 on 25 October 2014 19:17:54
os: Linux-3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07)
nodename: serveur-wapt
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 2
current working directory: /home/fabien
writing pidfile to /var/run/waptserver.pid
detected binary path: /usr/bin/uwsgi-core
setgid() to 33
setuid() to 117
your processes number limit is 3908
your memory page size is 4096 bytes
detected max file descriptor number: 65536
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to TCP address 127.0.0.1:8080 fd 3
Python version: 2.7.9 (default, Jun 29 2016, 13:11:10)  [GCC 4.9.2]
Python main interpreter initialized at 0x2596440
python threads support enabled
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 1237056 bytes (1208 KB) for 16 cores
*** Operational MODE: preforking ***
WSGI app 0 (mountpoint='') ready in 1 seconds on interpreter 0x2596440 pid: 21504 (default app)
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 21504)
spawned uWSGI worker 1 (pid: 21509, cores: 1)
spawned uWSGI worker 2 (pid: 21510, cores: 1)
spawned uWSGI worker 3 (pid: 21511, cores: 1)
spawned uWSGI worker 4 (pid: 21512, cores: 1)
spawned uWSGI worker 5 (pid: 21513, cores: 1)
spawned uWSGI worker 6 (pid: 21514, cores: 1)
spawned uWSGI worker 7 (pid: 21515, cores: 1)
spawned uWSGI worker 8 (pid: 21516, cores: 1)
spawned uWSGI worker 9 (pid: 21517, cores: 1)
spawned uWSGI worker 10 (pid: 21518, cores: 1)
spawned uWSGI worker 11 (pid: 21519, cores: 1)
spawned uWSGI worker 12 (pid: 21520, cores: 1)
spawned uWSGI worker 13 (pid: 21521, cores: 1)
spawned uWSGI worker 14 (pid: 21522, cores: 1)
spawned uWSGI worker 15 (pid: 21523, cores: 1)
spawned uWSGI worker 16 (pid: 21524, cores: 1)
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 817
Inscription : 10 juil. 2014 - 23:52
Contact :

22 mars 2017 - 08:31

Est-ce une debian avec environnement graphique ?
Fabien LAMAISON
Messages : 5
Inscription : 21 mars 2017 - 09:11

22 mars 2017 - 09:00

En effet, avec environnement graphique par defaut
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 817
Inscription : 10 juil. 2014 - 23:52
Contact :

22 mars 2017 - 10:00

Bonjour

Comme indiquée dans la doc

https://www.wapt.fr/fr/doc/Installation ... index.html

L’environnement graphique doit être désactivé ;

Je vous conseille de réinstaller une debian sans environement graphique
Fabien LAMAISON
Messages : 5
Inscription : 21 mars 2017 - 09:11

23 mars 2017 - 08:03

OK J'avais pas fait attention à ça...

J'ai désinstallé GMD3:

Code : Tout sélectionner

apt-get remove --auto-remove gdm3
apt-get purge --auto-remove gdm3
Le problème persiste, je vais devoir passer par la case RAZ et réinstallation... ARF!!
Question bête mais réinstallation du serveur veut forcément dire nouvelle génération de certificat ou je peux réutiliser les certificats générés auparavant?
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 817
Inscription : 10 juil. 2014 - 23:52
Contact :

23 mars 2017 - 11:54

Bonjour

Non il ne faut surtout pas régénérer de nouveau certificat :o , sinon vous allez devoir redéployer votre nouvelle clé publique sur tout vos postes !

Simon
Fabien LAMAISON
Messages : 5
Inscription : 21 mars 2017 - 09:11

25 mars 2017 - 10:41

Bonjour à tous,

Après réinstallation tout est OK. J'ai régénéré mon agent avec le certificat existant, je suis bien retombé sur le même hash pour l'installation et mes postes sont remontés tout seuls. J'ai réimporté mes paquets dans mon dépôt tout est bon.

Merci donc pour le rappel : lisez bien les tutos avant de vous lancer... :oops:
Avatar de l’utilisateur
vcardon
Expert WAPT
Messages : 84
Inscription : 06 oct. 2017 - 22:55
Localisation : Nantes, FR

07 oct. 2017 - 00:25

sfonteneau a écrit :
22 mars 2017 - 10:00
Bonjour

Comme indiquée dans la doc

https://www.wapt.fr/fr/doc/Installation ... index.html

L’environnement graphique doit être désactivé ;
Simon, dans la documentation, pourras tu mettre un bloc alerte pour faire ressortir le fait que Debian doit être installée sans interface graphique car les interfaces graphiques bouzillent les paramètres réseau (c'est un peu comme les navigateurs aujourd'hui qui vous redirigent vers un moteur de recherche quand vous avez tapé une bonne url, c'est juste chiant)

Vincent
Vincent CARDON
Tranquil IT
fludo67
Messages : 22
Inscription : 13 sept. 2016 - 14:23

30 nov. 2017 - 16:28

Bonjour,

sans avoir à réinstaller tout le serveur, en redémarrant le serveur en runlevel3 (mode réseau, sans serveur graphique) ça fonctionne ? (taper init 3 dans une fenêtre de terminal, ça vous renvoie sur la console en ligne de commande)

Pour forcer le serveur à démarrer en runlevel3, vous pouvez taper dans une fenêtre de terminal (compte root) la commande suivante:

Code : Tout sélectionner

sudo systemctl set-default runlevel3.target 
Répondre