foxit Corrupt

Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
yohannbrossard
Messages : 5
Inscription : 04 févr. 2019 - 16:34

19 déc. 2019 - 09:39

Bonjour, quand j'essaie d'importer foxit version 9 PROD, j'ai un file corrupt, MD5 mismatch.
Merci de votre aide.
Cdlt.
yohannbrossard
Messages : 5
Inscription : 04 févr. 2019 - 16:34

19 déc. 2019 - 11:22

J'ai le même problème avec TIS-WATP-DEV
yohannbrossard
Messages : 5
Inscription : 04 févr. 2019 - 16:34

19 déc. 2019 - 14:06

Il y a un problème dans votre doc,
cat > /etc/yum.repos.d/wapt.repo <<EOF
[wapt]
name=WAPT Server Repo
baseurl=https://wapt.tranquil.it/centos7/wapt-1.7/
enabled=1
gpgcheck=0
EOF

il manque " " dans l'adresse baseurl, ca ne marche pas sans.
Cdlt.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 393
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

19 déc. 2019 - 15:33

Bonjour yohannbrossard,
yohannbrossard a écrit :
19 déc. 2019 - 14:06
Il y a un problème dans votre doc,
cat > /etc/yum.repos.d/wapt.repo <<EOF
[wapt]
name=WAPT Server Repo
baseurl=https://wapt.tranquil.it/centos7/wapt-1.7/
enabled=1
gpgcheck=0
EOF

il manque " " dans l'adresse baseurl, ca ne marche pas sans.
Cdlt.
les quotes ne sont pas nécessaires (sur une installation standard centos7), en fait je n'en ai jamais eu besoin à vrai dire. Est ce que vous donnez des informations supplémentaire par rapport à votre installation pour savoir dans quel cas ça bug?

Si les téléchargement de paquets vous donnent des corruptions de somme de contrôle, il faudrait vérifier si vous avez pas un firewall filtrant qui fait des bidouilles avec les paquets TCP/IP quand ils passent. Si vous avez des informations complémentaires, ça pourrait aider.

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
yohannbrossard
Messages : 5
Inscription : 04 févr. 2019 - 16:34

19 déc. 2019 - 16:12

J'ai une installation en centos. Je viens de passez de la 1.6 à la 1.7, sans les " " , en faisant un yum Update, les sources n'allaient pas chercher les nouveau paquets 1.7. Cela me disait tis-waptserver et tis-waptsetup..... 1.6 already installed.

J'ai une dernière question : suite à ma migration,
lorsque je fais un wapt-get enable-check-certificate

j'obtiens :
FATAL ERROR : typeError: argument of type 'NoneType' is not iterable

Pourtant, mes certifs sont bons et j'ai suivi toute la doc.
Merci de votre aide.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 393
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

19 déc. 2019 - 18:40

yohannbrossard a écrit :
19 déc. 2019 - 16:12
J'ai une installation en centos. Je viens de passez de la 1.6 à la 1.7, sans les " " , en faisant un yum Update, les sources n'allaient pas chercher les nouveau paquets 1.7. Cela me disait tis-waptserver et tis-waptsetup..... 1.6 already installed.
ça veut dire que le cache local ne s'est pas mis à jour tout seul. Un yum cache clean aurait pu faire l'affaire. Le fait de rajouter des quote a du forcer le retéléchargement des métadonnées... Il faudra que je vérifie les timestamps sur les différents fichiers, ou bien les temps de conservation en cache donnés par le serveur web.
J'ai une dernière question : suite à ma migration,
lorsque je fais un wapt-get enable-check-certificate

j'obtiens :
FATAL ERROR : typeError: argument of type 'NoneType' is not iterable

Pourtant, mes certifs sont bons et j'ai suivi toute la doc.
Merci de votre aide.
Est ce que vous pourriez lancer la même commande avec un -l debug pour avoir un peu plus d'information.

La connexion en https au serveur passe bien si vous vous connecter avec un navigateur?

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
yohannbrossard
Messages : 5
Inscription : 04 févr. 2019 - 16:34

20 déc. 2019 - 14:05

Voici mon debug :

C:\windows\system32>wapt-get enable-check-certificate -l debug
Current loglevel : DEBUG
2019-12-20 14:02:47,582 DEBUG Default encoding : ascii
2019-12-20 14:02:47,582 DEBUG Setting encoding for stdout and stderr to cp850
2019-12-20 14:02:47,598 DEBUG Python path ['C:\\Program Files (x86)\\wapt', 'C:\\Program Files (x86)\\wapt', 'C:\\Program Files (x86)\\wapt\\python27.zip', 'C:\\Program Files (x86)\\wapt\\DLLs', 'C:\\Program Files (x86)\\wapt\\lib', 'C:\\Program Files (x86)\\wapt\\lib\\plat-win', 'C:\\Program Files (x86)\\wapt\\lib\\lib-tk', 'C:\\Program Files (x86)\\wapt', 'C:\\Program Files (x86)\\wapt\\lib\\site-packages', 'C:\\Program Files (x86)\\wapt\\lib\\site-packages\\pywin32-223-py2.7-win32.egg']
2019-12-20 14:02:47,598 INFO Using local waptservice configuration C:\Program Files (x86)\wapt\wapt-get.ini
2019-12-20 14:02:47,598 DEBUG Config file: C:\Program Files (x86)\wapt\wapt-get.ini
Using config file: C:\Program Files (x86)\wapt\wapt-get.ini
2019-12-20 14:02:47,615 DEBUG Thread 6196 is connecting to wapt db
2019-12-20 14:02:47,740 DEBUG Using host certificate C:\Program Files (x86)\wapt\private\DBAF34FF-77A5-11E5-9BAE-0C15E402E0FF.pem for repo global auth
2019-12-20 14:02:47,802 DEBUG Thread 6196 is connecting to wapt db
2019-12-20 14:02:47,802 DEBUG DB Start transaction
2019-12-20 14:02:47,802 DEBUG DB commit
2019-12-20 14:02:47,927 DEBUG Using host certificate C:\Program Files (x86)\wapt\private\DBAF34FF-77A5-11E5-9BAE-0C15E402E0FF.pem for repo wapt auth
2019-12-20 14:02:48,161 DEBUG Using host certificate C:\Program Files (x86)\wapt\private\DBAF34FF-77A5-11E5-9BAE-0C15E402E0FF.pem for repo wapt-host auth
2019-12-20 14:02:48,223 INFO User Groups:[]
2019-12-20 14:02:48,223 DEBUG WAPT base directory : C:\Program Files (x86)\wapt
2019-12-20 14:02:48,223 DEBUG Package cache dir : C:\Program Files (x86)\wapt\cache
2019-12-20 14:02:48,223 DEBUG WAPT DB Structure version;: 20190606
2019-12-20 14:02:48,223 DEBUG Loading ssl context with cert C:\Program Files (x86)\wapt\private\DBAF34FF-77A5-11E5-9BAE-0C15E402E0FF.crt and key C:\Program Files (x86)\wapt\private\DBAF34FF-77A5-11E5-9BAE-0C15E402E0FF.pem
2019-12-20 14:02:48,240 DEBUG Starting new HTTPS connection (1): srv-wapt.isto.cnrs-orleans.fr:443
2019-12-20 14:02:48,286 DEBUG https://srv-wapt.isto.cnrs-orleans.fr:443 "HEAD /ping HTTP/1.1" 200 0
Server certificate : C:\Program Files (x86)\wapt\ssl\server\srv-wapt.isto.cnrs-orleans.fr.crt
FATAL ERROR : TypeError: argument of type 'NoneType' is not iterable
Traceback (most recent call last):
File "<string>", line 1425, in <module>
File "<string>", line 1388, in main
File "<string>", line 339, in do_enable_check_certificate
TypeError: argument of type 'NoneType' is not iterable
Exception at 00441C2A: EPyTypeError:
exceptions.TypeError: argument of type 'NoneType' is not iterable.
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 962
Inscription : 10 juil. 2014 - 23:52
Contact :

20 déc. 2019 - 22:03

Si c'est possible, pouvez-vous nous fournir le fichier "C:\Program Files (x86)\wapt\ssl\server\srv-wapt.isto.cnrs-orleans.fr.crt"
Répondre