Contactez nous

Paquet: tis-pdfsam

Image tis-pdfsam
Description:
PDFSAM pdf split and merge tool, A free open source tool to manipulate PDF documents
- Version de WAPT installée : 1.3.13
- OS du serveur : Linux Debian : 8.10
- OS de la machine d'administration : Windows 7

Bonjour,

lorsque je tente d'installer la version 3.3.5-2 du paquet, WAPT me retourne l'erreur suivante :

installing tis-pdfsam
AttributeError: 'str' object has no attribute 'iteritems'

Pouvez-vous m'indiquer si il s'agit d'un problème connu de vos services ?

Cordialement,
Bonjour ccbe,
ccbe a écrit :
06 mars 2018, 14:19
- Version de WAPT installée : 1.3.13
- OS du serveur : Linux Debian : 8.10
- OS de la machine d'administration : Windows 7

Bonjour,

lorsque je tente d'installer la version 3.3.5-2 du paquet, WAPT me retourne l'erreur suivante :

installing tis-pdfsam
AttributeError: 'str' object has no attribute 'iteritems'

Pouvez-vous m'indiquer si il s'agit d'un problème connu de vos services ?

Cordialement,
Je viens de tester sur ma machine en WAPT 1.5RC1 et ça fonctionne correctement.

Je ne vois pas dans la syntaxe qu'est ce qu'il peut y avoir comme problème syntaxique par rapport à une version en 1.3.13...

Est ce que c'est un problème que vous rencontrez sur plusieurs postes? Est ce que vous pourriez essayer de l'installer avec la ligne de commande
wapt-get install -l debug tis-pdfsam

Cordialement,

Denis
Est ce que c'est un problème que vous rencontrez sur plusieurs postes? Est ce que vous pourriez essayer de l'installer avec la ligne de commande
wapt-get install -l debug tis-pdfsam
Bonjour,

J'ai essayé d'installer le paquet sur plusieurs postes de modèles distincts sans succès.

Voici ce que la ligne de commande me retourne pour tous les postes testés :

Code : Tout sélectionner

2018-03-07 14:56:25,621 CRITICAL Fatal error in install script: AttributeError:
'str' object has no attribute 'iteritems':
Traceback (most recent call last):
  File "c:\wapt\common.py", line 3557, in install_wapt
    exitstatus = setup.install()
  File "c:\users\root~1.ccb\appdata\local\temp\waptrqnh60\setup.py", line 15, in
 install
    install_msi_if_needed("pdfsam-v3.3.5.msi",properties='CHECK_FOR_UPDATES=fals
e SKIPTHANKSPAGE=Yes LOCALE_CODE=fr')
  File "c:\wapt\setuphelpers.py", line 3776, in install_msi_if_needed
    props = ' '.join(["%s=%s" % (k,v) for (k,v) in properties.iteritems()])
AttributeError: 'str' object has no attribute 'iteritems'

2018-03-07 14:56:25,937 CRITICAL Package ccbe-pdfsam not installed due to errors
 : AttributeError: 'str' object has no attribute 'iteritems'
FATAL ERROR : AttributeError: 'str' object has no attribute 'iteritems'
Traceback (most recent call last):
  File "<string>", line 1109, in <module>
  File "<string>", line 389, in main
  File "c:\wapt\common.py", line 4136, in install
    explicit_by=self.user if request in apackages else None
  File "c:\wapt\common.py", line 3630, in install_wapt
    raise e
AttributeError: 'str' object has no attribute 'iteritems'
Exception at 0043E0FA: EPyAttributeError:
exceptions.AttributeError: 'str' object has no attribute 'iteritems'.
Que me conseillez-vous?

Cordialement,

Marine