Contactez nous

Mise à jour Wapt Client

Share here your experience and thought about WAPT / Venez ici parlez de votre expérience avec Wapt, votre avis et vos envies
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,

Je cherche à mettre à jour le fichier Wapt-get.ini sur tous les postes de mon parc pour y intégrer le
allow_cancel_upgrade=0 qui me permet de forcer les mises à jours à l'extinction du PC.

Pour cela je le modifie directement sur le serveur le fichier .ini puis genère un client via la console qui me crée automatiquement un nouveau dépot privé "upgrade du client". Cependant, lorsque que je le déploie sur les PCs client le fichier wapt-get.ini n'est pas modifié et l'utilisateur peut toujours annulé les mise à jours.

Any ideas ?
Bonjour

Le waptagent n'embarque pas cette conf, ou alors il faut modifier le fichier ... c:\wapt\waptsetup\waptsetup.iss Puis régénérer un agent.

Le plus simple reste encore de pousser la configuration post-installation, exemple de paquet qui le fait :
https://wapt.tranquil.it/package_detail ... 6_all.wapt

Simon Fonteneau
Merci beaucoup !

C'est exactement ce que j'avais besoin je n'avais pas vu ce paquet.

Merci :)
sfonteneau

--- > j'ai testé ton paquet avant de le déployer, il fonctionne mais je n'ai pas le "allow_cancel_upgrade=0" mais "notify_user=0" dans le fichier wapt-get.ini. es ce la meme chose ? sachant que ce "notify_user" n'apparait dans aucune doc sur le site.
Bonjour,

"allow_cancel_uprade" n'est pas défini dans la liste des attributs de wapt-conf-policy :

Code : Tout sélectionner

print('Modify max_gpo_script_wait')
inifile_writestring(WAPT.config_filename,'global','max_gpo_script_wait',180)

print('Modify Preshutdowntimeout')
inifile_writestring(WAPT.config_filename,'global','pre_shutdown_timeout',180)

print('Disable Hyberboot')
inifile_writestring(WAPT.config_filename,'global','hiberboot_enabled',0)

print('Disable Notify User')
inifile_writestring(WAPT.config_filename,'global','notify_user',0)
Vous pouvez en revanche modifier le paquet pour le définir.

Code : Tout sélectionner

print('Disable Upgrade Cancellation')
inifile_writestring(WAPT.config_filename,'global','allow_cancel_upgrade',0)
Ca devrait répondre a votre attente.
sachant que ce "notify_user" n'apparait dans aucune doc sur le site.
Effectivement il n'est pas dans la documentation WAPT, ce sera chose faite prochainement

Cordialement,

Alexandre
Merci oui effectivement c'est ce que j'ai fait.

Je me suis laissé avoir par la description du paquet qui indiquait que le "allow_cancel_upgrade =0 " était renseigné sans prendre la peine de vérifier le script au préalable.

Merci beaucoup de votre réactivité !