[RESOLU] Installation package personnalisé

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

12 janv. 2021 - 14:35

Bonjour,
nous avons un client lourd afin de procéder à notre GMAO (corim.exe)
Ce client change assez régulièrement et je voulais l'intégrer à un modèle de paquet pour le déployer de manière automatique.
je précise que je suis nouveau sur wapt, j'ai installé le serveur, créé un groupe de test pour quelques ordi, fait notre portail d'applis qui fonctionne et déployer l'antivirus comme ça...
dès l'entrée dans le domaine tout se fait tout seul si l'ordi est dans le bon groupe, j'ai aussi intégré les maj windows .

Ma problématique :
lorsque je lance en ligne de commande sur un poste client la commande suivante, l'installation est ok :
msiexec /i "CorimProd client.msi" /quiet APPSERVERNAME=SRVCORIM APPSERVERPORTNUMBER=35000

j'ai voulu depuis la console créer un modèle de paquet depuis le menu outil en passant dans la rubrique "flags silencieux" les paramètres de la commande.
le programme s'est installé, mais pas d'icone sur le bureau ni même de menu dans la rebrique applications de l'odrinateur de test.

j'au donc voulu modifier le setup.py avec les paramètres :
def install():
killalltasks("corim.exe")
run(r'"4.40.7636.0_CorimProd Client.msi" /q appservername=srvgmao appserverportnumber=35000')

au lieu de install_msi_if_needed

mais depuis j'ai une erreur, et je ne sais pas je dois faire quelque chose une fois le setup.py modifié pour sa prise en compte correcte dans le paquet.

Merci d'avance pour vos réponses.
Dernière modification par MathieuL le 19 janv. 2021 - 10:58, modifié 1 fois.
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
Avatar de l’utilisateur
Gaetan
Messages : 93
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

13 janv. 2021 - 13:33

Bonjour,

je pense que la solution est de faire comme expliqué ici : https://www.wapt.fr/fr/doc/wapt-create- ... -arguments

Cela permet d'avoir install_msi_if_needed et les paramètres ;)
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

13 janv. 2021 - 14:59

Merci pour le retour.
j'ai tenté cette solution mais ça ne fonctionne pas plus même en installation depuis le portail d'application.

de tous les logiciels que j'ai tenté de rajouter j'ai office, corim, et le client sage qui ne fonctionnent pas...
Suis un peu perdu...

en PJ j'ai mis le message d'erreur que j'obtiens et ci-dessous les paramètres passés dans le setup.py :

# -*- coding: utf-8 -*-
from setuphelpers import *

uninstallkey = []

properties = {
'APPSERVERNAME':SRVGMAO,
'APPSERVERPORTNUMBER':35000,
}

def install():
install_msi_if_needed('4.40.7636.0_CorimProd Client.msi', properties = properties)

def uninstall():
pass
# put here what to do when package is removed from host
# implicit context variables are WAPT, control, user, params, run

def session_setup():
print('Session setup for %s' % control.asrequirement())
# put here what to do when package is configured inside a user session
# implicit context variables are WAPT, control, user, params
Pièces jointes
IMG_20210113_145308.jpg
IMG_20210113_145308.jpg (213.92 Kio) Consulté 1120 fois
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

13 janv. 2021 - 15:38

en fait je pense que j'ai un pb d'installation
j'ai regardé la vidéo suivant sur thunderbird : https://www.youtube.com/watch?v=z_EN2CBCTcY

sous pyscripter, j'ai des message d'erreur dès que j'essaie mes package, j'ai tenté en lançant pyscripter en user ou en admin...

voici le type d'erreur que j'ai :

*** Python 2.7.18 (v2.7.18:8d21aa21f2, Apr 20 2020, 13:19:08) [MSC v.1500 32 bit (Intel)] on win32. ***
*** Remote Python engine is active ***
>>>
*** Remote Interpreter Reinitialized ***
Command Line : install "D:\waptdev\cim-chrome_x64-wapt\WAPT\.."
Traceback (most recent call last):
File "D:\wapt\wapt-get.py", line 24, in <module>
from waptutils import __version__
File "D:\wapt\waptutils.py", line 42, in <module>
import requests
ImportError: No module named requests
>>>
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

13 janv. 2021 - 15:58

réinstallation pyscripter et python, je n'ai plus d'erreur mais installation en défaut toujours pour office, sage et corim, j'ai les modules install, etc... qui fonctionnent maintenant...
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
Avatar de l’utilisateur
vcardon
Expert WAPT
Messages : 176
Inscription : 06 oct. 2017 - 22:55
Localisation : Nantes, FR

13 janv. 2021 - 19:49

Bonjour.

Il n'est pas conseillé d'avoir la console d'administration WAPT sur le serveur WAPT. Le serveur devient alors un bien sensible car hébergeant de fait la clé de signature.

A vous de voir, en tout cas, c'est un no-no en matière de sécurité.
Vincent CARDON
Tranquil IT
Avatar de l’utilisateur
Gaetan
Messages : 93
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

14 janv. 2021 - 14:27

Bonjour,
quel est votre structure de déploiement actuellement ?
1 poste serveur/console/dev ?
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

18 janv. 2021 - 09:46

Bonjour,
actuellement en phase de test...
un serveur et quelques postes en test...
j'ai réussi à faire une install silencieuse de office.
me reste le client sage et le une appli de GMAO, but de post au départ.

une fois ce test terminé, on mettra les consoles sur les deux postes d'admin
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
Avatar de l’utilisateur
Gaetan
Messages : 93
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

18 janv. 2021 - 10:41

Bonjour,
les applications hors WAPT s'installent bien avec une commande silencieuse ?
MathieuL
Messages : 12
Inscription : 12 janv. 2021 - 13:14
Localisation : Normandie

18 janv. 2021 - 13:16

re,
oui j'ai mis en place l'antivirus (endpoint apexone) de la sorte ainsi que firefox, chrome et quelques autres...
voici ce que j'obtiens en tentant l'install de mon "corim.exe"

*** Remote Interpreter Reinitialized ***
Command Line : install "D:\waptdev\cim-corimprod-client-msi_x64_PROD-wapt\WAPT\.."
Using config file: D:\wapt\wapt-get.ini
Installing WAPT files D:\waptdev\cim-corimprod-client-msi_x64_PROD-wapt
2021-01-18 13:13:29,844 CRITICAL Fatal error in install script: CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "4.40.7636.0_CorimProd Client.msi" APPSERVERNAME=SRVGMAO APPSERVERPORTNUMBER=35000' returned non-zero exit status 1603.
Output::
Traceback (most recent call last):
File "D:\wapt\common.py", line 3877, in install_wapt
exitstatus = setup.install()
File "D:\waptdev\cim-corimprod-client-msi_x64_PROD-wapt\setup.py", line 12, in install
install_msi_if_needed('4.40.7636.0_CorimProd Client.msi', properties = properties)
File "D:\wapt\common.py", line 3831, in new_func
return func(*args,**kwargs)
File "D:\wapt\setuphelpers_windows.py", line 1102, in install_msi_if_needed
run(r'msiexec /norestart /q /i "%s" %s' % (msi,props),accept_returncodes=accept_returncodes,timeout=timeout,pidlist=pidlist)
File "D:\wapt\setuphelpers_windows.py", line 3718, in run
raise CalledProcessErrorOutput(proc.returncode,cmd,''.join(output))
CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "4.40.7636.0_CorimProd Client.msi" APPSERVERNAME=SRVGMAO APPSERVERPORTNUMBER=35000' returned non-zero exit status 1603.
Output:

FATAL ERROR : CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "4.40.7636.0_CorimProd Client.msi" APPSERVERNAME=SRVGMAO APPSERVERPORTNUMBER=35000' returned non-zero exit status 1603.
Output:
Exit code: 3
>>>


et voici ce que j'ai mis dans le fichier setup.py

uninstallkey = []

properties = {
'APPSERVERNAME':'SRVGMAO',
'APPSERVERPORTNUMBER':35000,
}

def install():
install_msi_if_needed('4.40.7636.0_CorimProd Client.msi', properties = properties)
Wapt 1.8.7334 entreprise - Windows Server 2016 Datacenter
Console d'admin sur le serveur lui même
Répondre