Erreur paquet wapt upgrader #Help

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
* Please prefix of the title of the thread to [SOLVED] if it is solved.
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.
renaud.counhaye
Messages : 23
Inscription : 13 déc. 2017 - 11:45

24 avr. 2018 - 10:42

Bonjour à tous

J'aimerais un coup de main rapide et efficace pour une situation bien ennuyante qui me pousse vraiment à bout. :evil:

Nous avions dans notre société 3 serveurs WAPT et récemment décider de migrer tout ce petit monde sur 1 tout neuf (1.5).
Mon idée alors est de déployer sur ces 3 anciens serveurs (1.3) et anciens clients le paquet wapt-upgrade générer sur le nouveau.

1er Problème, pas moyen d'accèder au repo du nouveau serveur je me tape un 403 du nginx et je trouve pas de doc pour le débloquer.

2eme Problème : j'ai utiliser la console du nouveau serveur pour download et edit le packet, puis j'ai transfèrer ce contenus vers le PC admin d'un ancien serveur pour "recompiler" le packet et pouvoir l'upload, résultat? FAIL.

Code : Tout sélectionner

2018-04-24 10:18:59,569 WARNING error: (2, 'GetFileVersionInfo:GetFileVersionInfoSize', 'Le fichier sp\xe9cifi\xe9 est introuvable.')
2018-04-24 10:18:59,569 WARNING error: (2, 'GetFileVersionInfo:GetFileVersionInfoSize', 'Le fichier sp\xe9cifi\xe9 est introuvable.')
2018-04-24 10:18:59,571 WARNING error: (2, 'GetFileVersionInfo:GetFileVersionInfoSize', 'Le fichier sp\xe9cifi\xe9 est introuvable.')
  ERROR building C:\waptdev\ymg-deploy-ymagis-nxt-wapt: [Errno 2] No such file or directory: 'patchs\\version'
En regardant dans le code python on remarque qu'il fait appel a un fichier qui n'existe même pas...

Code : Tout sélectionner

def update_control(entry):
    """Update package control file before build-upload"""
    waptget = get_file_properties(makepath('patchs','wapt-get.exe'))
    rev = open(makepath('patchs','version')).read().strip()
    entry.package = '%s-waptupgrade' % WAPT.config.get('global','default_package_prefix')
    entry.version = '%s-%s' % (waptget['FileVersion'],rev)
car en effet dans le dossier "patchs", se trouve que waptdeploy.exe et aucun dossier "version".

Le véritable problème étant que toutes les variables du python son remplie de façon dynamique, rendant le code difficilement lisible et adaptable si on souhaite ne pas utiliser les sha256.

In fine, est-ce que même ma solution va fonctionner et permetre aux anciens PC et rejoindre le nouveau serveur de façon fluide, ou devrais me torturer a l'idée de créer un powershell qui détruit l'ancien WAPT agent avant de simplement installer le nouveau... (j'ai déjà essayer en Python, mais évidement, tuer le service WAPT et lancer la désinstallation ne fait pas bon ménage).

J'espère que vous pourrez m'aider, ce projet de migration est bloquant chez nous...

Cordialement,

Renaud.
Renaud Counhaye
Technicien système réseaux
Central Functions Division
Ymagis Group
Image
Répondre