[résolu]Erreur lors de la signature d'un paquet

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
sones
Messages : 3
Inscription : 02 mai 2019 - 12:30

02 mai 2019 - 12:37

Ola,

Afin de pouvoir gérer la désinstallation des softs non déployés par WAPT, je cherche à créer un paquet vide pour accomplir cette tâche.

Le problème est que l'utilisation de la commande build-upload (build package aussi..) me renvoie une erreur après avoir demandé le password de la clé privée.
Password correct, mais qui contient des caractères spéciaux : tiret et accents.

J'ai testé en cmd, en powershell, en me connectant admin local de la machine.. rien n'y fait

le message d'erreur est : FATAL ERROR : EWaptMissingPrivateKey: The key matching the certificate C:\private\xxx.crt can not be found or decrypted


J'ai testé via la console, en utilisant un .msi le paquet est bien signé et atterri bien dans mon dépôt.

Savez-vous si le problème peut provenir de l'utilisation des caractères spéciaux ?
Avez-vous une solution de contournement ?
Merci :D
Dernière modification par sones le 13 mai 2019 - 10:35, modifié 1 fois.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 326
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

09 mai 2019 - 19:22

Bonjour Sones,
sones a écrit :
02 mai 2019 - 12:37
Afin de pouvoir gérer la désinstallation des softs non déployés par WAPT, je cherche à créer un paquet vide pour accomplir cette tâche.

Le problème est que l'utilisation de la commande build-upload (build package aussi..) me renvoie une erreur après avoir demandé le password de la clé privée.
Password correct, mais qui contient des caractères spéciaux : tiret et accents.

J'ai testé en cmd, en powershell, en me connectant admin local de la machine.. rien n'y fait

le message d'erreur est : FATAL ERROR : EWaptMissingPrivateKey: The key matching the certificate C:\private\xxx.crt can not be found or decrypted


J'ai testé via la console, en utilisant un .msi le paquet est bien signé et atterri bien dans mon dépôt.

Savez-vous si le problème peut provenir de l'utilisation des caractères spéciaux ?
Avez-vous une solution de contournement ?
Il y a peut être un problème d'unicode quelque part. Quelle version de WAPT, OS, etc. (cf. viewtopic.php?f=9&t=886) ?
Vous pouvez essayer de changer le mdp de la clef de signature à travers la console (si ça ne pose pas de problème d'unicode, menu "outils/ changer le mot de passe de la clef privée").

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
sones
Messages : 3
Inscription : 02 mai 2019 - 12:30

13 mai 2019 - 09:52

merci pour le retour:

- Version de WAPT installée (1.7 )
- OS du serveur (Linux Debian Stretch)
- OS de la machine d'administration/création des paquets (Win server 2016)

Je n'ai pas encore pris le temps de tester le changement de clé, je suis récemment passé de 50 machines dans l'inventaire, à plus de 400..

Le changement de clé implique également de signer à nouveau tous les paquets / distribuer le .pem sur les postes clients ?
Avatar de l’utilisateur
htouvet
Expert WAPT
Messages : 327
Inscription : 16 mars 2015 - 10:48
Contact :

13 mai 2019 - 09:59

Denis parlait du changement de "mot de passe" de la clé, pas de la clé elle même. La clé elle-même ne change pas, juste sa représentation chiffrée dans le .pem
Donc il n'y a pas d'incidence sur la signature des paquets.
Tranquil IT
sones
Messages : 3
Inscription : 02 mai 2019 - 12:30

13 mai 2019 - 10:35

:oops: ok le changement de password a résolu mon pb :D

Merci à tous les deux.
Répondre