[RESOLU] Erreur update_package Firefox

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
Manon_A
Messages : 1
Inscription : 08 juin 2021 - 14:02

08 juin 2021 - 14:09

Bonjour,
Je souhaite mettre à jour le paquet Firefox du store de wapt avec la fonction update_package.
ça télécharge bien firefox mais à la fin j'ai l'erreur suivante :
erreur_wapt.jpg
erreur_wapt.jpg (11.68 Kio) Consulté 181 fois
La variable est bien défini après comme suit:
def update_control_version(version=control.version.split('-')[0]):
control.version = '%s-%s'%(version,'102')
control.save_control_to_wapt()

Savez-vous comment résoudre cela ?
Je suis en version community 1.8.2.7334.

Merci à vous,
Bonne journée.
Manon
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 658
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

08 juin 2021 - 19:11

Bonjour,
les fonction def install() gardent une compatibilité 2.0/1.8.2, mais les fonction def update_packages() pas forcément. Dans votre cas ça fait probablement appel à une fonction qui n'existe pas dans la version 1.8.2. Les fonctions def install() resteront compatible 1.8.2 pour encore quelques mois le temps de la sortie de la version discovery 2.0 et que les utilisateurs community upgradent (si ils le désirent). La plupart des utilisateurs Entreprise ont déjà upgradés en 2.0. Vous pouvez modifier le script ou récupérer le def update_package() depuis un package plus ancien.
Cordialement,
Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
tristarauch
Messages : 1
Inscription : 22 juil. 2021 - 03:52

22 juil. 2021 - 04:19

super c'est bien sa ! merci pour ton aide
Répondre