Paquet mRemoteNG

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
elelay
Messages : 27
Inscription : 20 oct. 2020 - 12:39

12 juil. 2021 - 12:08

Bonjour,

Deux petites modifications sont à effectuer pour la compatibilité avec python3:

Lignes 116 et 117:

Code : Tout sélectionner

 # Il manquait les parenthèses
 print("Current %s WAPT package version is : %s" % (software_name,current_version))
 print("Latest %s version available is : %s" % (software_name,software_version))

Aussi, l'import de BeautifulSoup a changé.
Alternative pour éviter de tout modifier :

Code : Tout sélectionner


import bs4 as BeautifulSoup

Le reste fonctionne parfaitement !

Cordialement,

Étienne
Version de WAPT Server : 2.0 Entreprise
Console installée sur un Windows Server 2019
Serveur Debian 10 Buster
Répondre