[RESOLU] Problème avec task_exists et delete_task

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
* Please prefix of the title of the thread to [SOLVED] if it is solved.
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.
f4242
Messages : 33
Inscription : 23 nov. 2016 - 20:51

11 oct. 2017 - 22:32

Bonjour,

La fonction task_exists() semble toujours retourner false. Si j'essais d'utiliser delete_task() directement, je reçois l'erreur suivante: KeyError: "GoogleUpdateTaskMachineCore doesn't exists".

Pour le moment, j'utilise un run_notfatal pour effectuer la suppression de la tâche planifiée:
run_notfatal('schtasks /Delete /TN GoogleUpdateTaskMachineCore /F')

Le paquet tis-flashplayer tente de supprimer la tâche Adobe Flash Player Updater avec ces fonctions et celle-ci n'est effectivement pas supprimée des postes.
Avatar de l’utilisateur
htouvet
Expert WAPT
Messages : 298
Inscription : 16 mars 2015 - 10:48
Contact :

12 oct. 2017 - 09:40

Bonjour,
Ces deux fonctions se basent sur l'API Windows ITaskScheduler V1.0
Microsoft recommande la version 2.0 ici https://msdn.microsoft.com/en-us/librar ... s.85).aspx

Je pense que les tâches créées avec la nouvelle interface ne sont pas visible par la V1.0 de l'interface.
Les fonctions de setuphelpers sont donc obsolètes...

TODO...
Tranquil IT
Floflobel
Messages : 127
Inscription : 15 oct. 2015 - 17:32

25 mai 2018 - 17:38

Bonjour,

Le problème semble toujours d’actualité. Dans la documentation il y a marqué qu'il faut mettre le nom de la tâche sans .job mais ça ne fonctionne toujours pas.

Avez-vous plus d'info à ce sujet ?
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 285
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

28 mai 2018 - 00:46

Bonjour Floflobel,
Floflobel a écrit :
25 mai 2018 - 17:38
Le problème semble toujours d’actualité. Dans la documentation il y a marqué qu'il faut mettre le nom de la tâche sans .job mais ça ne fonctionne toujours pas.

Avez-vous plus d'info à ce sujet ?
Si c'est un problème bloquant pour vous, vous pouvez soumettre un patch ou payer un dev pour le faire. Pour le suivi de ce bug, j'ai créé une entrée sur le roundup (https://roundup.tranquil.it/wapt/issue956). Avec un peu de chance ça devrait pouvoir rentrer dans la prochaine release 1.6.1, sinon ça sera dans la suivante.

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le wiki WAPT
Répondre