[RESOLU] Première utilisation de WAPT est un échec

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée, version complète ET numéro de build (2.2.1.11957 / 2.2.2.12337 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Les versions 1.8.2 et antérieures ne sont plus maintenues. Les seules questions acceptées vis à vis de la version 1.8.2 sont liés à la mise à jour vers une version supportée (2.1, 2.2, etc.)
* Préciser OS du serveur (Linux / Windows) et version (Debian Buster/Bullseye - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
ng3
Messages : 16
Inscription : 11 juil. 2022 - 10:46

11 juil. 2022 - 11:11

Bonjour,

La solution WAPT réponds à de nombreuses problématiques au sein de mon entreprise. J'ai donc décidé de faire un poc sur un ensemble de machines, de tester l'outil sur une période de quelques mois sur l'ensemble des postes utilisateurs avant de monter éventuellement sur une version Entreprise.

Voici mon setup d'installation :
- Serveur WAPT : RHEL 7.6, 2vCPU, 4Go RAM
- Console d'administration WAPT sur un poste utilisateur pour faire les premiers tests.

Pour l'installation de WAPT sur le serveur, j'ai suivi la documentation de la 2.2. -> https://www.wapt.fr/fr/doc/wapt-server- ... based.html
Pour l'installation de la console WAPT, j'ai également suivi la documentation de la 2.2. J'ai récupéré le paquet waptsetup-tis.exe sur mon serveur wapt -> https://www.wapt.fr/fr/doc/wapt-configuration.html
Pour la configuration de la console WAPT (premier exécution en tant qu'administrateur), j'ai généré une nouvelle paire de clés.

Les problèmes :
- J'ai le message d'erreur suivant lorsque j'essaie de générer un agent WAPT : "Erreur lors de la création du waptagent.exe : Erreur lors du chargement de l'agent WAPT vers le dépôt :"
- Je ne peux pas resigner les paquets déjà présents dans le dépôt privé : "EWaptbadSignature: Check_package_signature failed for test-chrome..."

A savoir également, que je pensais que le problème venait du certificat que j'ai généré pour l'utilisateur de la console WAPT. J'en ai donc généré d'autres pour essayer de résoudre le problème mais c'est toujours KO. Enfin, je n'ai rien trouvé de très parlant dans les logs du serveur.

Je vous remercie par avance pour votre aide précieuse.

Excellente journée.
Dernière modification par ng3 le 12 juil. 2022 - 16:46, modifié 1 fois.
- Version de WAPT installée -> Discovery 2.2
- OS du serveur -> Ubuntu 22.04
- OS de la machine d'administration/création des paquets -> Windows Server
ng3
Messages : 16
Inscription : 11 juil. 2022 - 10:46

11 juil. 2022 - 12:59

Petite mise à jour :
Je ne peux également plus importer de packages depuis le repo WAPT. J'ai le message d'erreur suivant : THttpClientSocket.WGet:st...:443/nom_du_package hash failure :(
- Version de WAPT installée -> Discovery 2.2
- OS du serveur -> Ubuntu 22.04
- OS de la machine d'administration/création des paquets -> Windows Server
ng3
Messages : 16
Inscription : 11 juil. 2022 - 10:46

12 juil. 2022 - 16:45

Bonjour,

Evidemment le problème venait de mon côté. Accès internet KO depuis le serveur wapt.
- Version de WAPT installée -> Discovery 2.2
- OS du serveur -> Ubuntu 22.04
- OS de la machine d'administration/création des paquets -> Windows Server
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 973
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

12 juil. 2022 - 17:15

Bonjour ng3,

merci pour le retour. Le message est en effet pas très convivial... On va voir pour corriger cela.

Vous passez par un proxy ou vous avez un accès direct à internet? Vous aviez un DROP de paquet à ce moment là ou bien un REJECT?

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
ng3
Messages : 16
Inscription : 11 juil. 2022 - 10:46

05 oct. 2022 - 11:04

Bonjour,

Effectivement, je passais pas un proxy. Malheureusement, je n'ai pas de détail sur le DROP / REJECT.

Merci.

Cordialement.
- Version de WAPT installée -> Discovery 2.2
- OS du serveur -> Ubuntu 22.04
- OS de la machine d'administration/création des paquets -> Windows Server
Répondre