Probleme deploiement paquet en administrateur

Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
eric
Messages : 29
Inscription : 11 mars 2018 - 08:22

01 mai 2021 - 09:51

Bonjour,
version 1.8.2.72767
Je souhaite installer un paquet pour une suite logiciel de gestion EBP pour mon établissement. Le fournisseur m'a donné une ligne de commande
EBPOL_2020_LigneOL_Compta_12_3_1_8211.exe /s NETWORK=TRUE PERSONALIZED=TRUE WEBCHECKED=FALSE.

lorsque je l'installe avec cette commande run(r'EBPOL_2020_LigneOL_Compta_12_3_1_8211.exe /s NETWORK=TRUE PERSONALIZED=TRUE WEBCHECKED=FALSE')

elle ne fonctionne pas avec le compte system en effet depuis la console pyscripter en install cela fonctionne si je suis sous administrator, par contre si je déploie avec le compte system cela ne fonctionne pas.
j'ai positionné le service Waptservice en tant que .\administrateur et cela fonctionne. Mais après différentes lectures sur le forum cela pose un souci de sécurité et de plus il faut que je passe sur toute les machines (environ 250 machines fastidieux)

De plus je n'arrive pas à faire fonctionner la commande run_as_admin(r'EBPOL_2020_LigneOL_Compta_12_3_1_8211.exe /s NETWORK=TRUE PERSONALIZED=TRUE WEBCHECKED=FALSE') pyscripter me renvoie une erreur à chaque fois
igne de Commande : install "c:\waptdev\ader-test-wapt\WAPT\.."
Using config file: C:\Program Files (x86)\wapt\wapt-get.ini
Installing WAPT files c:\waptdev\ader-test-wapt
2021-05-01 09:18:40,750 CRITICAL Fatal error in install script: TypeError: running_as_admin() takes no arguments (1 given):
Traceback (most recent call last):
File "C:\Program Files (x86)\wapt\common.py", line 3876, in install_wapt
exitstatus = setup.install()
File "c:\waptdev\ader-test-wapt\setup.py", line 9, in install
running_as_admin('EBPOL_2020_LigneOL_Compta_12_3_1_8211.exe')
TypeError: running_as_admin() takes no arguments (1 given)

FATAL ERROR : TypeError: running_as_admin() takes no arguments (1 given)




seulement si celle-ci pourrait résoudre mon souci. Enfin la commande run_as_administrator n'existe pas comme préciser dans certains posts ?

Merci beaucoup de votre aide
Eric
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 644
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

18 mai 2021 - 15:38

l'impresonnation (ie l'équivalent de sudo sous Linux) est assez capricieux sous Windows. Une option assez déterministe est de créer une tâche planifier à exécution immédiate, mais bon, ça serait quand même plus facile d'avoir un sudo qui fonctionne...
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
Répondre