ERROR building package

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
* Please prefix of the title of the thread to [SOLVED] if it is solved.
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 285
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

30 mars 2018 - 18:43

Bonjour Mathieu,
Mathieu a écrit :
30 mars 2018 - 12:05
en attendant une solution je suis passer sur un autre package lui aussi volumineux (AdobeCC) j'ai exactement le même soucis

ERROR building N:\futur-AdobeCC_2018-wapt: Bad magic number for file header

est-ce un problème de WAPT avec les packages volumineux ?
on a déjà eu à traiter des paquets bien plus volumineux, et je connais plusieurs admins qui déploient du AdobeCC avec WAPT, donc non, ce n'est pas juste un problème de WAPT avec les paquets volumineux.

Est ce que vous pourriez tester avec différentes taille de logiciel pour voir à partir de quelle taille ça plante chez vous? Quelle quantité de RAM/Swap vous avez sur votre machine? Est ce que le disque dur n'est pas plein?

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le wiki WAPT
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

03 avr. 2018 - 08:35

Est ce que vous pourriez tester avec différentes taille de logiciel pour voir à partir de quelle taille ça plante chez vous? Quelle quantité de RAM/Swap vous avez sur votre machine? Est ce que le disque dur n'est pas plein?
Pour le test des différentes taille : J'ai fait Office 2016 (2Go) qui fonctionne après j'ai deux appli une de 6.38Go qui à l'erreur de build et l'autre de 3.13Go avec l'erreur.

Mon dossier de waptdev ce trouve sur le serveur wapt en partage pour permettre l’accès à tous les techniciens. J'ai donc fait le test de build/upload sur mon poste mais je me retrouve avec la même erreur.

Sur notre serveur wapt nous avons 2010 Mo de RAM et 879 de SWAP ( ce n'est pas le serveur final).

Pour le disque nous avons de la place sur le serveur.


htouvet a écrit : Apparemment, cela serait un problème avec la librairie ZipFile de Python.
Pouvez-vous essayer d'ouvrir le fichier n:\futur-Datastage_11-1_all.wapt qui doit être créé
C'est un fichier ZIP que 7-Zip par exemple doit pouvoir ouvrir et dézipper
Si 7Zip n'y arrive pas, c'est que la librairie Zipfile de python a un problème...

Dans le processus de signature qui suit la création du Zip, on remplace dans le Zip le fichier control et on ajouter le manifest et le certificat. C'est cette phase qui a l'air de pose problème parce qu'une entrée du Zip dans la phase précédente est incorrecte.
Je trouve beaucoup de post sur internet concernant le module zipfile mais je ne comprend pas comment le régler.
Avatar de l’utilisateur
htouvet
Expert WAPT
Messages : 298
Inscription : 16 mars 2015 - 10:48
Contact :

03 avr. 2018 - 09:15

Bonjour,
J'ai refait le test avec un paquet de 5G qui passe (build et install), que je peux dézipper avec 7zip mais avec un warning de problème d'entête...
On investigue...
Tranquil IT
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

24 avr. 2018 - 11:33

Bonjour,

je reviens vers vous si vous aviez une piste pour la résolution du problème qui est toujours présent ?
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

05 mai 2018 - 22:11

j'ai enfin reussi a packager Photoshop Element et Adobe CC

pour photoshop pas de soucis.

Par contre avec Adobe je me retrouve avec un message d'erreur :

Code : Tout sélectionner

Uploading C:\Temp\dev\futur-AdobeCC_2018_2018.0.0-4_all.wapt: 6762126720 / 6762126720
Done Uploading C:\Temp\dev\futur-AdobeCC_2018_2018.0.0-4_all.wapt
FATAL ERROR : HTTPError: 413 Client Error: Request Entity Too Large for url: /api/v3/upload_packages
Exit code:  3
j'ai donc modifier le fichier de conf grace viewtopic.php?t=1158 pour augmenter la taille mais maintenant j'ai une autre erreur :

Code : Tout sélectionner

FATAL ERROR : HTTPError: 504 Server Error: Gateway Time-out for url: /api/v3/upload_packages
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

16 mai 2018 - 08:12

je ne sait pas pourquoi mais l'erreur n'est plus presente sur les packages Adobe CC et Photoshop Element.

Mais toujours sur mon package de 3 Go malgré le changement de poste pour la création du package.

Code : Tout sélectionner

ERROR building N:\futur-Datastage-wapt: Bad magic number for file header
Ce que je comprend pas c'est que l'erreur pour Adobe CC est parti mais quand je fait le Build-Upload j'ai l'erreur

Code : Tout sélectionner

FATAL ERROR : HTTPError: 504 Server Error: Gateway Time-out for url: /api/v3/upload_packages
mais le package est quand même présent dans la console même après modification de la ligne dans le fichier de conf concernant le time-out.
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 768
Inscription : 10 juil. 2014 - 23:52
Contact :

16 mai 2018 - 18:16

Bonjour

Suite a notre échange en privé. J'ai pu essayer de construire le paquet wapt que vous m'avez envoyé.

Cela fonctionne chez moi.

Pouvez-vous essayer avec la dernière nightly ?

https://wapt.tranquil.it/wapt/nightly/w ... -fab3d82b/

Simon
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

19 mai 2018 - 08:45

Je viens d'effectuer la mise a jour vers la nightly j'ai toujours le même problème en reprenant le projet

Code : Tout sélectionner

ERROR building Y:\futur-Visual_Studio_2015_Pro-wapt: Bad magic number for file header
0 packages successfully built
1 packages failed 
List of errors :
Y:\futur-Visual_Studio_2015_Pro-wapt
Buildind and uploading packages to https://futwapt
FATAL ERROR : Exception: No package to upload
Exit code:  3
j'ai essayer en créant un package cela a fonctionné pour Visual Studio

par contre j'ai toujours le soucis sur mon autre package que ça soit en reprenant le projet ou en le créant a nouveau

Code : Tout sélectionner

  ERROR building C:\Temp\futur-DataStage_V11-wapt: Bad magic number for file header
0 packages successfully built
1 packages failed 
List of errors :
C:\Temp\futur-DataStage_V11-wapt
Buildind and uploading packages to https://futwapt
FATAL ERROR : Exception: No package to upload
Exit code:  3
j'ai voulu faire un essaie en faisant un package du logiciel en compressant le contenu ça fonctionne c'est pas beau mais ça fonctionne. Je pense que dans le contenu du package il y a un fichier qui le gène pour le build. Du coup faut que je copie le .zip sur le poste décompresser puis installer.
Avatar de l’utilisateur
Mathieu
Messages : 35
Inscription : 18 août 2016 - 10:24

20 mai 2018 - 12:08

je n'ai pas recontrer le soucis pour le moment mais maintenant j'ai l'erreur

Code : Tout sélectionner

Uploading C:\Temp\futur-AdobeCC_2018_2018.0.0-15_all.wapt: 6762126924 / 6762126924
Done Uploading C:\Temp\futur-AdobeCC_2018_2018.0.0-15_all.wapt
FATAL ERROR : HTTPError: 500 Server Error:  for url: https://futwapt/api/v3/upload_packages
Exit code:  3
>>> 
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 285
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

22 mai 2018 - 16:16

Bonjour Mathieu,
Mathieu a écrit :
20 mai 2018 - 12:08
je n'ai pas recontrer le soucis pour le moment mais maintenant j'ai l'erreur

Code : Tout sélectionner

Uploading C:\Temp\futur-AdobeCC_2018_2018.0.0-15_all.wapt: 6762126924 / 6762126924
Done Uploading C:\Temp\futur-AdobeCC_2018_2018.0.0-15_all.wapt
FATAL ERROR : HTTPError: 500 Server Error:  for url: https://futwapt/api/v3/upload_packages
Exit code:  3
>>> 
Est ce que vous pourriez regarder dans le fichier /var/log/syslog /var/log/nginx/error.log, /var/log/nginx/access.log au moment où vous avez votre erreur? Éventuellement monter le loglevel à debug dans votre fichier waptserver.ini.

J'ai vu dans votre premier post que vous êtes sous Debian. Est ce que vous pourriez upgrader en Stretch. Dans tous les cas la version Jessie passe en End of Life le 6 juin prochain.

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le wiki WAPT
Répondre