Contactez nous

[RESOLU] Wapt : Erreur de socket #11004

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,

j'aurais une question concernant les erreurs : An unhandled exception has occured Socket Error # 11004.

Cette erreur arrive de manière aléatoire.
Je fais l'installation de WAPT sur plusieurs sites et sur certains je n'ai aucun souci et sur d'autres j'ai cette erreur qui arrive de temps en temps et qui repart souvent comme elle est arrivée.
Je n'ai pas encore trouvé d'où cela peut provenir.
Avez-vous des pistes à me donner ?

Merci.

Anne-Laure
Bonjour Anne-Laure,
alf a écrit :
17 mai 2018, 14:14
j'aurais une question concernant les erreurs : An unhandled exception has occured Socket Error # 11004.

Cette erreur arrive de manière aléatoire.
Je fais l'installation de WAPT sur plusieurs sites et sur certains je n'ai aucun souci et sur d'autres j'ai cette erreur qui arrive de temps en temps et qui repart souvent comme elle est arrivée.
Je n'ai pas encore trouvé d'où cela peut provenir.
Avez-vous des pistes à me donner ?
ça ressemble beaucoup à un problème de resolveur DNS, avec une configuration incorrecte comme par exemple deux DNS entrées sur le poste, un vers l'AD et l'autre vers google.

Cordialement,

Denis
Bonjour,

merci pour votre retour.

J'ai fait les modifications concernant les DNS mais je rencontre plusieurs autres erreurs de façon aléatoire.
Je n'arrive pas à comprendre d'où peuvent provenir mes soucis car certaines consoles fonctionnent correctement et d’autres non sans avoir pourtant fait des paramétrages différents.

Je vais vous faire un topo des erreurs rencontrées.
- Repository access error. Socket Error Host not found / Server acces error : Socket #110XX Host not found dans la fenêtre Configuration WAPT locale.
- Unable to get https server certificate for url https://wapt.xxxxxx.xxxx gaierror: [Errno 11004] getaddrinfo failed lors de la récupération du certificat dans la fenêtre Configuration WAPT locale.
- An unhandled exception has occured ConnectTimeout: HTTPSConnectionPool(host='wapt.xxxx.xxx',port=443): Max retries exceeded with url: /wapt/Packages (Caused by ConnectTimedError(<urllib3.connection.VerifiedHTT... object at 0x09966810>, 'Connection to wapt.xxxxx.xxxx timed out. (connecttimeout=2')) lors de l'actualisation des paquets disponibles.
- An unhandled exception has occured New connectionError:< urllib3.connection.VerifiedHTTPSConnection object at 0x100552B0>: Failed to establish a new connection: [Errno 11004] getaddrinfo failed lors de l'importation de paquet
- Erreur sur le serveur WAPT: Socket Error # 11004 lors de l'ouverture de la console WAPT.
- Erreur sur le serveur WAPT: Socket Error # 11001 Host not found lors de la reconnexion à la console suite à une erreur lors de la suppression d'un paquet.
- Erreur de timeout.

Il y a surement des erreurs du à des problèmes DNS mais je ne comprends pourquoi ce n'est pas stable.
Y a-t-il quelque chose à faire pour avoir plus de stabilité sur les consoles ?

Merci d'avance.

Anne-Laure
Re-bonjour,

j'ai aussi cette erreur "Impossible de récupérer l'action. Error on server: Timeout, client did not send result within 5.0 s99" lors de l'installation de paquet sur la console.

Je rencontre aussi le problème lors du lancement des installations des paquets manuellement.
Je lance les installations et sur la popup qui arrive je n'ai pas pas d'actions lancées, pas d'erreurs, pas d'actions skipped et pas d'erreurs serveurs. Et mon paquet n'apparait pas dans l'onglet Général et pourtant il est bien dans l'inventaire machine.
Comment puis-je forcer l'installation ?

Merci.

Anne-Laure
Bonjour,
alf a écrit :
24 mai 2018, 15:21
j'ai aussi cette erreur "Impossible de récupérer l'action. Error on server: Timeout, client did not send result within 5.0 s99" lors de l'installation de paquet sur la console.

Je rencontre aussi le problème lors du lancement des installations des paquets manuellement.
Je lance les installations et sur la popup qui arrive je n'ai pas pas d'actions lancées, pas d'erreurs, pas d'actions skipped et pas d'erreurs serveurs. Et mon paquet n'apparait pas dans l'onglet Général et pourtant il est bien dans l'inventaire machine.
Comment puis-je forcer l'installation ?
merci d'ouvrir un post différent pour chaque problème, ça permet de faire un meilleur suivi et ça aide les autres personnes qui peuvent tomber sur le même problème de plus facilement trouver leur solution.

Cordialement,

Denis
Bonjour,

effectivement je suis d'accord.
Je me suis rendue compte une fois les messages envoyés que mon sujet avait été placé en résolu.
J'ai donc fait une autre demande en reprenant ces informations.
Par contre, je n'ai pas dissocié les sujets.

Je ferais cela plus tard.

Merci pour le retour.

Cordialement,

Anne-Laure FAU