Contactez nous

Package TIS-dotnetfx3.5

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
* Please prefix of the title of the thread to [SOLVED] if it is solved.
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.

Bonjour

J'ai récupéré le package TIS-dotnetfx3.5 que j'essaye de déployer sur quelques machines (windows 10) mais j'obtiens toujours ce message d'erreur :
Installing adv-dotnetfx3.5
Exception: Erreur lors de l'installation de adv-dotnetfx3.5 (=3.5.30729-11): erreurs dans les paquets [[u'adv-dotnetfx3.5 (=3.5.30729-11)', PackageEntry('adv-dotnetfx3.5','3.5.30729-11') ]]
Traceback (most recent call last):
File "C:\Program Files (x86)\wapt\waptservice\waptservice.py", line 1151, in run
self.running_task.run()
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 405, in pwrapper
return func(*arg, **kwargs)
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 464, in run
self._run()
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 884, in _run
self.result.get('errors',[])))
Exception: Erreur lors de l'installation de adv-dotnetfx3.5 (=3.5.30729-11): erreurs dans les paquets [[u'adv-dotnetfx3.5 (=3.5.30729-11)', PackageEntry('adv-dotnetfx3.5','3.5.30729-11') ]]
C'est un problème du package ou de mon infra/client ?

Merci.

- Version de WAPT installée 1.5
- OS du serveur Debian Stretch
- OS de la machine d'administration/création des paquets Windows 10
Bonjour Benoît,
benoitpatin a écrit :
05 juillet 2018, 14:11
Bonjour

J'ai récupéré le package TIS-dotnetfx3.5 que j'essaye de déployer sur quelques machines (windows 10) mais j'obtiens toujours ce message d'erreur :
Installing adv-dotnetfx3.5
Exception: Erreur lors de l'installation de adv-dotnetfx3.5 (=3.5.30729-11): erreurs dans les paquets [[u'adv-dotnetfx3.5 (=3.5.30729-11)', PackageEntry('adv-dotnetfx3.5','3.5.30729-11') ]]
Traceback (most recent call last):
File "C:\Program Files (x86)\wapt\waptservice\waptservice.py", line 1151, in run
self.running_task.run()
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 405, in pwrapper
return func(*arg, **kwargs)
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 464, in run
self._run()
File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 884, in _run
self.result.get('errors',[])))
Exception: Erreur lors de l'installation de adv-dotnetfx3.5 (=3.5.30729-11): erreurs dans les paquets [[u'adv-dotnetfx3.5 (=3.5.30729-11)', PackageEntry('adv-dotnetfx3.5','3.5.30729-11') ]]
C'est un problème du package ou de mon infra/client ?
Je pense que l'installeur dotnetfx3.5 n'est pas le même pour windows 7 et windows 10, et que celui qui est packagé est celui pour windows 7. Est ce que tu pourrais essayer de dézipper le paquet et lancer le msi à la main pour vérifier le message d'erreur.

Merci,

Denis
Salut Denis,

En regardant le code python du package, si le windows est une version > à la version 6.1 alors il lance une commande DISM. Donc l'exe n'est pas en cause. Par contre la commande DISM demande un paramètre "source". Généralement quand je fais l'install "à la mano" du dot net 3.5 je monte un iso windows 10 et je lui spécifie le chemin de sources\sxs. Il faudrait peut être embarquer le fichier cab dans votre package ?