[RESOLU][WAPT 1.6 - Debian 9] - Problème kerberos

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
*Afin de faciliter l'aide dans ce forum, merci de préciser dans vos posts les éléments suivants :
- Version de WAPT installée (1.3.9 / 1.3.13 / 1.5 / 1.6)
- OS du serveur (Linux / Windows)
- OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.
james
Messages : 23
Inscription : 18 sept. 2018 - 16:37

10 janv. 2019 - 12:53

Bonjour,
je n'arrive plus à activer kerberos, il y a une erreur avec le paquet libnginx-mod-http-auth-spnego .. :(

nginx dlopen() "/usr/share/nginx/modules/ngx_http_auth_spnego_module.so" failed (/usr/share/nginx/modules/ngx_http_auth_spnego_module.so : cannot open shared ...)
nginx configurtion file /etc/nginx/nginx.conf test failed

https://wapt.tranquil.it/debian/wapt-1. ... n/n/nginx/

Déjà, en stretch, il m'installe le paquet libnginx-mod-http-auth-spnego 1.10.3-1 alors qu'un 1.10.3-2 existe ..
Je suis allé regardé le contenu des paquets :
- 1.10.3-1 : il manque la lib dans le paquet ngx_http_auth_spnego_module.so
-1.10.3-2 : la lib est la ngx_http_auth_spnego_module.so

Je pense qu'il y a un soucis de votre côté ..
Dernière modification par james le 22 janv. 2019 - 10:39, modifié 1 fois.
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 303
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

14 janv. 2019 - 19:59

Bonjour James,
james a écrit :
10 janv. 2019 - 12:53
Bonjour,
je n'arrive plus à activer kerberos, il y a une erreur avec le paquet libnginx-mod-http-auth-spnego .. :(

nginx dlopen() "/usr/share/nginx/modules/ngx_http_auth_spnego_module.so" failed (/usr/share/nginx/modules/ngx_http_auth_spnego_module.so : cannot open shared ...)
nginx configurtion file /etc/nginx/nginx.conf test failed

https://wapt.tranquil.it/debian/wapt-1. ... n/n/nginx/

Déjà, en stretch, il m'installe le paquet libnginx-mod-http-auth-spnego 1.10.3-1 alors qu'un 1.10.3-2 existe ..
Je suis allé regardé le contenu des paquets :
- 1.10.3-1 : il manque la lib dans le paquet ngx_http_auth_spnego_module.so
-1.10.3-2 : la lib est la ngx_http_auth_spnego_module.so

Je pense qu'il y a un soucis de votre côté ..
en effet, il y avait une erreur dans la chaine de build. Je viens de faire la correction, les dépôts wapt-1.5 et wapt-1.6 devraient être OK. Je vais faire un peut de ménage dedans et le mettre la chaine de build sur le github tranquilit.

Le maintient des modules nginx est vraiment fastidieux... Même si c'est du chargement dynamique, il faut recompiler tout nginx à chaque fois pour être sûr que l'on a la bonne ABI. J'espère que le projet Debian pourra l'inclure par défaut dans le prochaine release majeure!

N'hésitez pas à revenir sur le forum si vous avez toujours des soucis.

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
james
Messages : 23
Inscription : 18 sept. 2018 - 16:37

22 janv. 2019 - 10:38

Bonjour Denis,
ça fonctionne mieux désormais merci ! Sachant que ce paquet n'est pas présent en debian testing, il y a très peu de chance de le voir arriver dans la prochaine stable ... Merci, cordialement
Répondre