Contactez nous

Problèmes avec la communication wapt

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
* Please prefix of the title of the thread to [SOLVED] if it is solved.
* Merci de préfixer le titre du thread par [RESOLU] si il est résolu.

Bonsoir

- Version installée de la version du serveur WAPT: 1.5.1.16
- Serveur OS Debian GNU / Linux 9.3 (extension)


Je me permets de communiquer avec vous car j'ai des problèmes avec la communication de mes nœuds (windows) vers les serveurs du référentiel.

Master Vlan Server 1
Référentiel de serveurs 1 Vlan 2
Référentiel de serveurs 2 Vlan 3
Nœuds PC VLAN 2 et 3

Apparemment, il existe un blocage, mais ce qui n’est pas, c’est que le port ou le service est bloqué. Auparavant, un pare-feu autorisait la connexion, mais lorsqu’une commutation de pare-feu vers les serveurs de référentiel n’existait pas et était redirigée vers le serveur maître, Le problème est que le maître est en dehors du réseau local via MPLS et consomme beaucoup de bande passante.

Nous avons des services ouverts et des ports
-http,
-ssh,
-port tcp 8088
-port tcp 22000 (Syncthing)

Avez-vous une solution pour résoudre le problème?

En avance, merci.

Tres cordialement,

Angel Herrera
Hola Angel!

If you are more confortable with English, we can also go the Yankee way :-) My Spanish is a bit rusty...
Angel Herrera a écrit :
12 janv. 2019 - 00:32
Master Vlan Server 1
Référentiel de serveurs 1 Vlan 2
Référentiel de serveurs 2 Vlan 3
Nœuds PC VLAN 2 et 3
So you have 3 debian 9.3 servers :
- waptserver on vlan1 in datacenter (debian 9.3)
- waptrepo1 on vlan2 on site1 (debian 9.3)
- waptrepo2 on vlan3 on site2 (debian 9.3)

And computers on physical site site1 and site2

Your issue is that computers are connecting to waptserver on vlan1 instead of connecting to their respective waptrepo1 or waptrepo2. Computers on vlan2 should connect to waptrepo1 and computers on vlan3 should connect to waptrepo2.

Currently there are two ways to help waptagent to download from the nearest repository : wapt-get.ini configuration or DNS configuration. The easiest thing to do is to configure explicitly the repository on your windows client using a configuration package like [1] setting the line repo_url.

Code : Tout sélectionner

repo_url=http://waptrepo1.mydomain.local/wapt
You create two such packages and then apply them respectively to the computers on site1 and site2.

Cheers,

Denis

[1] https://store.wapt.fr/package_details?p ... 6_all.wapt