[RESOLU] Debian 9 - postconf

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée (1.3.9 / 1.3.13 / 1.5 )
* Préciser OS du serveur (Linux / Windows) et version (Debian Jessie/Stretch - CentOS 7 - Windows Server 2012/2016)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
keeper
Messages : 1
Inscription : 26 janv. 2019 - 18:10

26 janv. 2019 - 18:17

Bonjour

j'ai installé WAPT sur un debian9 en précisant "strech" comme dépot

l'installe se passe bien mais au postconf j'ai ceci comme erreur

Traceback (most recent call last):
File "/opt/wapt/waptserver/scripts/postconf.py", line 42, in <module>
import jinja2
File "/opt/wapt/lib/python2.7/site-packages/jinja2/__init__.py", line 33, in <module>
from jinja2.environment import Environment, Template
File "/opt/wapt/lib/python2.7/site-packages/jinja2/environment.py", line 13, in <module>
import weakref
File "/usr/lib/python2.7/weakref.py", line 14, in <module>
from _weakref import (
ImportError: cannot import name _remove_dead_weakref


je suis perdu car je lance bien le script postconf.sh

Merci d'avance pour vos lumières :-)
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 827
Inscription : 10 juil. 2014 - 23:52
Contact :

15 avr. 2019 - 21:19

Pouvez-vous tenter avec la dernière version ?

http://wapt.tranquil.it/wapt/nightly/wa ... -7158724f/
had69
Messages : 2
Inscription : 11 juil. 2019 - 10:41

11 juil. 2019 - 10:46

Bonjour,

Je me permet d'actualiser ce sujet car j'ai exactement le même message à l’exécution du script post conf.

J'ai la version 1.7 de Wapt et j'utilise la version 10 de debian (buster)

Merci
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 326
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

11 juil. 2019 - 11:16

Bonjour had69,
had69 a écrit :
11 juil. 2019 - 10:46
Bonjour,

Je me permet d'actualiser ce sujet car j'ai exactement le même message à l’exécution du script post conf.

J'ai la version 1.7 de Wapt et j'utilise la version 10 de debian (buster)

Merci
on a pas encore testé et validé l'environnement Debian Buster. Est ce que vous pourriez ouvrir un nouveau thread, le problème est probablement lié au changement de version.

Cordialement,

Denis
Denis Cardon - Tranquil IT Systems
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
had69
Messages : 2
Inscription : 11 juil. 2019 - 10:41

11 juil. 2019 - 15:31

du coup j'ai réinstallé le serveur en debian 9.9 et le script fonctionne bien mieux

comme quoi suivre les précos des fois ça aide...

en tout cas merci pour la réactivité !
Répondre