[RÉSOLU] Soucis création paquet MSI Kaspersky

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée ( 1.3.13 / 1.5 / 1.7.4)
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
Avatar de l’utilisateur
Gaetan
Messages : 53
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

08 août 2019 - 14:58

Bonjour à tous,

j'ai eu le soucis décrit sur ce sujet :

viewtopic.php?t=1891

J'ai donc tenté de contourner en utilisant ce code :

Code : Tout sélectionner

# -*- coding: utf-8 -*-
import subprocess

uninstallkey = []

def install():
    print('installing tls-agent-kav-10-installer')
    subprocess.call(["msiexec", "/i 'Kaspersky_Network_Agent.msi' /qn /l*vx c:\windows\temp\nag_inst.log SERVERADDRESS='\\kamoulox' DONT_USE_ANSWER_FILE=1 EULA=1 PRIVACYPOLICY=1"])
Qui tourne mais m'affiche ceci :
wapt.PNG
wapt.PNG (17.28 Kio) Consulté 309 fois
Avec de la recherche, j'ai lu que cela viendrai de la ligne msiexec et ses paramètres.
Cette ligne fonctionne bien lancée par powershell.

Auriez-vous une idée ?

Merci.

- Version de WAPT installée (1.7)
- OS du serveur Linux et version CentOS 7
- OS de la machine d'administration/création des paquets Windows 10
Dernière modification par Gaetan le 23 août 2019 - 11:19, modifié 3 fois.
- Version de WAPT installée (1.7)
- OS du serveur Linux et version CentOS 7
- OS de la machine d'administration/création des paquets Windows 10
Avatar de l’utilisateur
jpele
Messages : 9
Inscription : 04 mars 2019 - 12:01
Localisation : Nantes

08 août 2019 - 15:13

Bonjour,

Il n'est pas nécessaire d'utiliser subprocess. Je vous invite à tester l'installation avec la fonction "install_msi_if_needed".
Un CTRL + clique gauche vous permettra d'obtenir toutes les fonctions et paramètres.

Pour vos nouveaux paquets, je vous conseillerais d'utiliser l'outil "générer un modèle de paquet" disponible dans la console WAPT et documenter ici :
https://www.wapt.fr/fr/doc/wapt-create- ... index.html

Cordialement,
Jimmy
Avatar de l’utilisateur
Gaetan
Messages : 53
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

09 août 2019 - 09:13

Bonjour,

j'ai mal expliqué mon début.
J'ai déjà fait avec cette fonction, mais cela me donne le même résultat que le sujet indiqué dans mon premier message.

La solution n'est pas donnée entièrement et je ne sais pas comment refaire un installeur propre comme indiqué.

Merci.
- Version de WAPT installée (1.7)
- OS du serveur Linux et version CentOS 7
- OS de la machine d'administration/création des paquets Windows 10
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 938
Inscription : 10 juil. 2014 - 23:52
Contact :

09 août 2019 - 13:51

Bonjour en suivant la doc de zabbix: https://www.zabbix.com/documentation/4. ... es/win_msi

Et en suivant la doc wapt :https://doc.ad.tranquil.it/wapt/fr/doc/ ... -arguments

Ça fonctionne

Code : Tout sélectionner

# -*- coding: utf-8 -*-
from setuphelpers import *

uninstallkey = []

def install():
    print('installing zabbix-agent')

    properties = {
        'LOGTYPE':'file',
        'LOGFILE':r'c:\za.log',
        'ENABLEREMOTECOMMANDS':'1',
        'SERVER':'192.168.6.76',
        'LISTENPORT':'12345',
        'SERVERACTIVE':'::1',
        'HOSTNAME':'myHost',
        'TLSCONNECT':'psk',
        'TLSACCEPT':'psk',
        'TLSPSKIDENTITY':'MyPSKID',
        'TLSPSKFILE':r'c:\mykey.psk',
        'TLSCAFILE':r'c:\temp\f.txt1',
        'TLSCRLFILE':r'c:\temp\f.txt2',
        'TLSSERVERCERTISSUER':'"My CA"',
        'TLSSERVERCERTSUBJECT':'"My Cert"',
        'TLSCERTFILE':r'c:\temp\f.txt5',
        'TLSKEYFILE':r'c:\temp\f.txt6',
        'ENABLEPATH':'1',
        'INSTALLFOLDER':r'c:\toto.log',
        'SKIP':'fw'}
    install_msi_if_needed('zabbix_agent-4.2.4-win-amd64-openssl.msi', properties = properties,force=True)
Il faut adapter maintenant
Avatar de l’utilisateur
Gaetan
Messages : 53
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

09 août 2019 - 15:41

Bonjour sfonteneau,

merci pour ton explication ça fonctionne bien mieux et j'ai compris mes erreurs.

voici le code, si ça peux aider d'autres personnes :

Code : Tout sélectionner

# -*- coding: utf-8 -*-
from setuphelpers import *

uninstallkey = []

properties = {
	'SERVERADDRESS':'10.31.8.47',
	'DONT_USE_ANSWER_FILE':1,
    	'EULA':1,
	'PRIVACYPOLICY':1,
    	'LAUNCHPROGRAM':1
	}

def install():

    print('installing tls-agent-kav-10-installer')
    if os.path.isdir('C:\Program Files (x86)\Kaspersky Lab\NetworkAgent') == False:
        install_msi_if_needed('Kaspersky Network Agent.msi', properties = properties )
    else:
        print ('Kaspersky Agent already installed')
- Version de WAPT installée (1.7)
- OS du serveur Linux et version CentOS 7
- OS de la machine d'administration/création des paquets Windows 10
Répondre