[RESOLU] GPO non fonctionnelle

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée ( 1.3.13 / 1.5 / 1.7.4)
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
Robin
Messages : 9
Inscription : 27 sept. 2019 - 11:55

27 sept. 2019 - 15:27

Bonjour à tous,

Je test WAPT dans l'entreprise dans laquelle je travail.
C'est pour le moment totalement fonctionnelle sur notre infrastructure mais on a installer directement avec l'agent sur quelques postes.

J'aimerai le mettre en production sur l'intégralité de notre parc mais j'ai un problème au niveau de la GPO de déploiement dispo sur la doc.

J'ai donc bien créer une GPO en suivant la doc wapt sur notre serveur windows 2008 R2.

GPO ordinateur -> Stratégies -> Param. Windows -> Script -> démarrage

waptdeploy.exe dans mon dossier script et en paramètre les info que j'ai récupéré sur mon serveur wapt :
--hash=(monhash) --minversion=1.7.4.6165 --wait=15
CaptureGPO.PNG
CaptureGPO.PNG (9.33 Kio) Consulté 219 fois
Mais je n'ai aucune remontée de ma GPO. (Mes autres GPO fonctionne sans problème)

Je fais appel à vous pour m'aiguiller sur mon problème, j'ai déjà regardé les sujets qui s'en rapprochent, ça ne règle rien.
Help me! :D

Poste Windows 10 1903
WAPT 1.7.4
Yoann
Messages : 13
Inscription : 24 juil. 2019 - 09:39

27 sept. 2019 - 16:01

Bonjour,

En ne spécifiant pas explicitement l'adresse de téléchargement de l'agent WAPT en argument (--waptsetupurl="http://xxxxxx/wapt/waptagent.exe"), l'utilitaire waptdeploy.exe va tenter de récupérer cette adresse automatiquement via plusieurs requêtes DNS :
  • Enregistrement de type SRV _wapt._tcp
  • Enregistrement de type CNAME en wapt.mondomaine.com
  • Enregistrement de type A en wapt.mondomaine.com
Si aucune requête DNS ne retourne de résultat, l'agent WAPT ne peut alors pas être téléchargé et installé sur les machines.

Cordialement.
Robin
Messages : 9
Inscription : 27 sept. 2019 - 11:55

30 sept. 2019 - 10:07

Yoann a écrit :
27 sept. 2019 - 16:01
Bonjour,

En ne spécifiant pas explicitement l'adresse de téléchargement de l'agent WAPT en argument (--waptsetupurl="http://xxxxxx/wapt/waptagent.exe"), l'utilitaire waptdeploy.exe va tenter de récupérer cette adresse automatiquement via plusieurs requêtes DNS :
  • Enregistrement de type SRV _wapt._tcp
  • Enregistrement de type CNAME en wapt.mondomaine.com
  • Enregistrement de type A en wapt.mondomaine.com
Si aucune requête DNS ne retourne de résultat, l'agent WAPT ne peut alors pas être téléchargé et installé sur les machines.

Cordialement.
Je vien d'essayer en ajoutant l'argument --waptsetupurl

--waptsetupurl="http://10.8.100.40/wapt/waptagent.exe" --hash=monhash --minversion=1.7.4.6165 --wait=15

Je n'avais toujours pas de résultat positif, mais le script s'exécuter pas pour un problème de droit... :oops: oooops

Merci de ton aide
Répondre