[RESOLU] tis-disable-sleepmode & Windows 10

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum
* English support on www.reddit.com/r/wapt
* Le support en français se fait sur ce forum
* Merci de préfixer le titre du thread par [RESOLU] s'il est résolu.
* Préciser version de WAPT installée ( 1.3.13 / 1.5 / 1.7.4)
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
Avatar de l’utilisateur
dvinouze
Messages : 4
Inscription : 21 mai 2019 - 08:41

28 nov. 2019 - 09:24

Bonjour,
J'ai un comportement étrange sur notre parc, les postes sous Windows 10 ayant le paquet tis-disable-sleepmode demande le mot de passe de session utilisateur lorsqu'un utilisateur souhaite de nouveau se servir du poste.
Ce n'est pas le comportement attendu, l'écran doit simplement se couper après 20 minutes d'inactivités.

Code : Tout sélectionner

run('"powercfg.exe" -change -monitor-timeout-ac 20')
run('"powercfg.exe" -change -monitor-timeout-dc 20')
Ai-je loupé une option ?
Merci
- Version de WAPT installée (1.7.4)
- OS du serveur (Debian Stretch 9.9)
- OS de la machine d'administration/création des paquets (Windows 10 - 1903)
Avatar de l’utilisateur
agauvrit
Expert WAPT
Messages : 228
Inscription : 17 nov. 2016 - 10:25
Localisation : Nantes
Contact :

28 nov. 2019 - 11:08

Bonjour,

Pour désactiver ce comportement, vous pouvez tenter d'ajouter ces commande au paquet qui devraient désactiver la demande de mot de passe

Code : Tout sélectionner

run('"powercfg" /SETDCVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0')
run('"powercfg" /SETACVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0')
Avatar de l’utilisateur
dvinouze
Messages : 4
Inscription : 21 mai 2019 - 08:41

28 nov. 2019 - 16:54

Merci pour votre réponse.
J'ai tester ces commandes

Code : Tout sélectionner

run('"powercfg.exe" -change -monitor-timeout-ac 20')
run('"powercfg.exe" -change -monitor-timeout-dc 20')
run('"powercfg.exe" /SETDCVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0')
run('"powercfg.exe" /SETACVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0')
Cela ne fonctionne pas ; le poste utilisateur demande toujours une authentification !
En revanche, cette méthode fonctionne mais grâce à des GPO
- Version de WAPT installée (1.7.4)
- OS du serveur (Debian Stretch 9.9)
- OS de la machine d'administration/création des paquets (Windows 10 - 1903)
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 942
Inscription : 10 juil. 2014 - 23:52
Contact :

28 nov. 2019 - 19:54

Du coup configurable en paquet wapt avec une clé registre:

https://getadmx.com/?Category=Windows_1 ... OnResume_2

Registry Hive HKEY_LOCAL_MACHINE
Registry Path Software\Policies\Microsoft\Power\PowerSettings\0e796bdb-100d-47d6-a2d5-f7d2daa51f51
Value Name ACSettingIndex
Value Type REG_DWORD
Enabled Value 1
Disabled Value 0
Répondre