problème d'installation de paquet

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée, version complète ET numéro de build (2.2.1.11957 / 2.2.2.12337 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Les versions 1.8.2 et antérieures ne sont plus maintenues. Les seules questions acceptées vis à vis de la version 1.8.2 sont liés à la mise à jour vers une version supportée (2.1, 2.2, etc.)
* Préciser OS du serveur (Linux / Windows) et version (Debian Buster/Bullseye - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
jkerneur
Messages : 1
Inscription : 11 mars 2021 - 10:58

21 sept. 2021 - 12:06

- Version de WAPT installée (1.8.2 )
- OS du serveur (Linux ) et version (ubuntu 20.04 LTS)
- OS de la machine d'administration/création des paquets (Windows 10)


Bonjour,

Nous avons déployé WAPT 1.8.2 Community sur notre réseau .L'outil fonctionne correctement et nous avons pu créer nos propre paquets .

Nous rencontrons cependant un problème avec un package que nous avons créé .

A l'origine il s'agit d'un .exe généré par la console ESET qui déploie un agent et l'antivirus.

le déploiement ce passe bien et l'antivirus et l'agent s'installent correctement sur le poste.
Cependant WAPT continu de le réinstaller sur le poste .
Dans les logs on peux constater que wapt considère que le paquet n'est pas installé.
Ya t'il un paramètre ou une clé qui permette d'acquitter une installation ?
voici l'erreur que me remonte la console :

Code : Tout sélectionner

Installing me-eset-security_V2(=7.2.1266.0-2)

Installing me-eset-security_V2(=7.2.1266.0-2)


Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptservice\service.py", line 1892, in run
    self.running_task.run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 653, in run
    self._run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 1126, in _run
    self.result.get('errors',[])))
Exception: Erreur lors de l'installation de [u'me-eset-security_V2(=7.2.1266.0-2)']: erreurs dans les paquets [[PackageRequest(package=u'me-eset-security_V2',version=(Version('7.2.1266.0'), 2),architectures=[u'x64'],locales=['fr'],maturities=[u'PROD'],target_os=[u'windows'],min_os_version=Version('10.0.19042'),max_os_version=Version('10.0.19042')), PackageEntry(u'me-eset-security_V2',u'7.2.1266.0-2' maturity=u'PROD'), u'Traceback (most recent call last):\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 4957, in install\n    force=force\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 3965, in install_wapt\n    raise e\nCalledProcessErrorOutput: Command \'"ESMC_Installer_x64_fr_FR.exe" --silent --accepteula\' returned non-zero exit status 5002.\nOutput:\n']]

Exception: Erreur lors de l'installation de [u'me-eset-security_V2(=7.2.1266.0-2)']: erreurs dans les paquets [[PackageRequest(package=u'me-eset-security_V2',version=(Version('7.2.1266.0'), 2),architectures=[u'x64'],locales=['fr'],maturities=[u'PROD'],target_os=[u'windows'],min_os_version=Version('10.0.19042'),max_os_version=Version('10.0.19042')), PackageEntry(u'me-eset-security_V2',u'7.2.1266.0-2' maturity=u'PROD'), u'Traceback (most recent call last):\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 4957, in install\n    force=force\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 3965, in install_wapt\n    raise e\nCalledProcessErrorOutput: Command \'"ESMC_Installer_x64_fr_FR.exe" --silent --accepteula\' returned non-zero exit status 5002.\nOutput:\n']]
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptservice\service.py", line 1892, in run
    self.running_task.run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 653, in run
    self._run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 1126, in _run
    self.result.get('errors',[])))
Exception: Erreur lors de l'installation de [u'me-eset-security_V2(=7.2.1266.0-2)']: erreurs dans les paquets [[PackageRequest(package=u'me-eset-security_V2',version=(Version('7.2.1266.0'), 2),architectures=[u'x64'],locales=['fr'],maturities=[u'PROD'],target_os=[u'windows'],min_os_version=Version('10.0.19042'),max_os_version=Version('10.0.19042')), PackageEntry(u'me-eset-security_V2',u'7.2.1266.0-2' maturity=u'PROD'), u'Traceback (most recent call last):\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 4957, in install\n    force=force\n  File "C:\\Program Files (x86)\\wapt\\common.py", line 3965, in install_wapt\n    raise e\nCalledProcessErrorOutput: Command \'"ESMC_Installer_x64_fr_FR.exe" --silent --accepteula\' returned non-zero exit status 5002.\nOutput:\n']]
et voici ce que remonte l'audit :

Code : Tout sélectionner

Auditing me-eset-security_V2(=7.2.1266.0-2)


Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptservice\service.py", line 1892, in run
    self.running_task.run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 653, in run
    self._run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 1209, in _run
    self.result.append(u'%s: %s' % (package,self.wapt.audit(package,force = self.force)))
  File "C:\Program Files (x86)\wapt\common.py", line 6558, in audit
    raise Exception('Package %s is not installed' % package)
Exception: Package me-eset-security_V2(=7.2.1266.0-2) is not installed

Exception: Package me-eset-security_V2(=7.2.1266.0-2) is not installed
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptservice\service.py", line 1892, in run
    self.running_task.run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 653, in run
    self._run()
  File "C:\Program Files (x86)\wapt\waptservice\waptservice_common.py", line 1209, in _run
    self.result.append(u'%s: %s' % (package,self.wapt.audit(package,force = self.force)))
  File "C:\Program Files (x86)\wapt\common.py", line 6558, in audit
    raise Exception('Package %s is not installed' % package)
Exception: Package me-eset-security_V2(=7.2.1266.0-2) is not installed
D'avance merci pour vos retours.

Salutations
Répondre