[RESOLU] Kerberos et Selfservice

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
Renaud Villet
Messages : 10
Inscription : 23 janv. 2020 - 14:12

04 mai 2022 - 11:19

Bonjour
nous avons configuré l'utilisation de Kerberos pour l'enregistrement des machines, et cela fonctionne bien. En revanche, depuis la version 2.1, le self service ne se lance plus, sans aucun message d'erreur, sur les postes clients, mais il se lance bien quand on passe use_kerberos=0 dans le wapt-get.ini.
Merci de votre aide
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1353
Inscription : 10 juil. 2014 - 23:52
Contact :

04 mai 2022 - 14:25

Bonjour

Pour l'authentification kerberos dans le selfservice

Le wapt-get.ini sur l'agent est t'il bien dans ce mode :

Code : Tout sélectionner

[global]
use_kerberos=True
service_auth_type=waptserver-ldap
Et sur le serveur wapt dans /opt/wapt/conf/waptserver.ini

Code : Tout sélectionner

[options]
ldap_auth_server = srvads.mydomain.lan
ldap_auth_base_dn = DC=mydomain,DC=lan
ldap_account_service_login = wapt-ldap@mydomain.lan
ldap_account_service_password = password


Ce qui est oublier souvent c'est d'ajouter ldap_account_service_login et ldap_account_service_password
Sans ça le serveur authentifie bien le user mais ne peu pas savoir les groupes dont il est membre
Renaud Villet
Messages : 10
Inscription : 23 janv. 2020 - 14:12

05 mai 2022 - 14:07

OK super, ça fonctionne.
Merci !
smandel
Messages : 51
Inscription : 05 mai 2022 - 11:30

05 mai 2022 - 17:50

Bonjour,

pour ma part la conf a bien été appliquée mais rien ne se passe également.
L'authentification est fonctionnelle pour les agents voulant se connecter au serveur.
A quel endroit est-il possible de voir des logs ?

Merci.
smandel
Messages : 51
Inscription : 05 mai 2022 - 11:30

05 mai 2022 - 17:56

C'est tout bon après avoir ajouté :

Code : Tout sélectionner

ldap_auth_ssl_enabled = False
Merci !
Répondre