Paquet teamviewer

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
elelay
Messages : 27
Inscription : 20 oct. 2020 - 12:39

12 juil. 2021 - 11:48

Bonjour,

Il y a un souci avec le paquet teamviewer au niveau de la fonction update_package()
Le check de version provoque une erreur et ne met donc pas à jour le paquet.

Code : Tout sélectionner


URL used is: https://www.teamviewer.com/en/download/windows/
2021-07-12 11:34:27,534 CRITICAL Fatal error in update_package function: EWaptSetupException: Fatal error : Version are not corresponding, please verify: 15.19.5 too different of: 15.19.3.0):
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\waptpackage.py", line 2928, in call_setup_hook
    hookdata = hook_func()
  File "D:\waptdev\sdis85-teamviewer_x64-wapt\setup.py", line 89, in update_package
    error("Version are not corresponding, please verify: %s too different of: %s)" % (version, version_from_file))
  File "C:\Program Files (x86)\wapt\waptutils.py", line 1841, in error
    raise EWaptSetupException('Fatal error : %s' % reason)
waptutils.EWaptSetupException: Fatal error : Version are not corresponding, please verify: 15.19.5 too different of: 15.19.3.0)

Personnellement, pour le check de version j'utilise parse_version du module pkg_resources

Solution :

Code : Tout sélectionner


from pkg_resources import parse_version

# Checking version from file
    version_from_file = get_version_from_binary(latest_bin)
    if parse_version(version_from_file) < parse_version(version):
        print(f'Found a more recent version {version} > {version_from_file}')
        remove_file(latest_bin)

if not isfile(latest_bin):
        print("Downloading: %s" % latest_bin)
        wget(url_dl, latest_bin, proxies=proxies)
        
Cordialement,

Étienne
Version de WAPT Server : 2.0 Entreprise
Console installée sur un Windows Server 2019
Serveur Debian 10 Buster
Répondre