[RESOLU] Création Paquet Google Workplace sync

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.6.1 / 1.7.4 / 1.8.2 / etc.) AINSI QUE l'édition Enterprise / Community
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter Camille ou Faustine au service commercial Tranquil IT au 02.40.97.57.55
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

20 juil. 2021 - 14:49

Bonjour,

J'ai créé le paquet google work place sync à l'aide du msi qu'il y a sur leur site.
Voici le code généré:

Code : Tout sélectionner

def install():
    # declaring local variables
    package_version = control.get_software_version()

    # installing the package
    install_msi_if_needed('enterprise_gsync.msi',
        min_version=package_version,
    )
L'installation fonctionne en mode "debug" sur la console wapt mais ne fonctionne pas sur l'environement de test.
WAPT self service me demande de forcer l'installation mais cela ne change rien.
J'aimerais savoir s'il existe des log que je pourrais consulter afin de resoudre mon problème.
Dernière modification par MorganeDeveho le 23 juil. 2021 - 17:09, modifié 1 fois.
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

20 juil. 2021 - 15:00

Le paquet parvient tout de même à s'installer sur certains postes.
Avatar de l’utilisateur
Gaetan
Messages : 139
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

20 juil. 2021 - 15:44

Bonjour,

via pyscripter le paquet fonctionne-t-il aussi ?
Dernière modification par Gaetan le 20 juil. 2021 - 16:40, modifié 1 fois.
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

20 juil. 2021 - 15:55

J'utilise visual studio code.
Le script fonctionne via ce logiciel
Avatar de l’utilisateur
Gaetan
Messages : 139
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

20 juil. 2021 - 16:26

Le paquet est en erreur sur la console lors de la mise en dépendance ?
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

20 juil. 2021 - 16:41

Lorsque je test le paquage via visual studio code, ça fonctionne.
Mais l'installation remonte en erreur sur certains postes.
Est ce qu'il y a des logs que je pourrais vérifier / regarder ?
Avatar de l’utilisateur
Gaetan
Messages : 139
Inscription : 08 août 2019 - 10:16
Localisation : Toulouse

20 juil. 2021 - 16:47

En cliquant sur le paquet en erreur dans la colonne statut qu'est-ce qui s'affiche ?
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

21 juil. 2021 - 16:10

Exception: Erreur lors de l'installation de ['dvo-google-workspace-sync(=4.3.49.0-3)']: erreurs dans les paquets [[PackageRequest(package='dvo-google-workspace-sync',version=(Version('4.3.49.0'), 3),architectures=['x64'],locales=['fr'],maturities=['PROD'],tags=['windows-10', 'windows'],min_os_version=Version('10.0.19043'),max_os_version=Version('10.0.19043')), PackageEntry('dvo-google-workspace-sync','4.3.49.0-3' maturity='PROD',target_os='windows'), 'Traceback (most recent call last):\n File "C:\\Program Files (x86)\\wapt\\common.py", line 5011, in install\n result = self.install_wapt(full_fname(p.filename),\n File "C:\\Program Files (x86)\\wapt\\common.py", line 4010, in install_wapt\n raise e\n File "C:\\Program Files (x86)\\wapt\\common.py", line 3923, in install_wapt\n exitstatus = setup.install()\n File "C:\\Windows\\TEMP\\waptqitjceb_\\setup.py", line 12, in install\n File "C:\\Program Files (x86)\\wapt\\common.py", line 3877, in new_func\n return func(*args, **kwargs)\n File "C:\\Program Files (x86)\\wapt\\setuphelpers_windows.py", line 1279, in install_msi_if_needed\n run(r\'msiexec /norestart /q /i "%s" %s\' % (msi, props), accept_returncodes=accept_returncodes, timeout=timeout, pidlist=pidlist)\n File "C:\\Program Files (x86)\\wapt\\setuphelpers_windows.py", line 4029, in run\n raise CalledProcessErrorOutput(proc.returncode, cmd, \'\'.join(output))\nwaptutils.CalledProcessErrorOutput: Command \'msiexec /norestart /q /i "enterprise_gsync.msi" \' returned non-zero exit status 1603.\nOutput:\n']]
Avatar de l’utilisateur
vcardon
Expert WAPT
Messages : 187
Inscription : 06 oct. 2017 - 22:55
Localisation : Nantes, FR

21 juil. 2021 - 17:57

Vincent CARDON
Tranquil IT
MorganeDeveho
Messages : 19
Inscription : 20 juil. 2021 - 14:42

23 juil. 2021 - 11:49

Merci pour votre aide.
Le problème venait enfait des versions d'office.
Le paquet s'installait bien sur les pc qui avaient office x64 et pas sur ceux x86
Répondre