Impossible d'installer un package

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

15 janv. 2019 - 14:43

Bonjour,
Je suis nouveau sur ce forum. Bonne année 2019.

L'installation en version 1.3 du serveur et client en Windows 7 fonctionnait très bien. Mais les packages sont maintenant destinés aux nouvelles versions.

Je n'ai pas réussi à mettre à jour le serveur de 1.3 vers 1.6, j'ai dû tout réinstaller et redéployer le l'agent via mon antivirus Kaspersky.

Mon architecture est la suivante :
Wapt Server version 1.6.2.7 sur Windows Server 2012 R2.
PC client sur Windows 7 mais surtout Windows 10 en version 1709.
J'ai mis les exceptions liées à Wapt dans ma console centrale Kaspersky.

L'agent Wapt sur mon PC fonctionne. Je le trouve bien celui-ci dans ma console.
Lorsque j'essaie d'installer un package de Firefox (ou autre), j'ai le message de waptconsole indiquant 0 actions lauched, 1 erros, 0 skipped, 0 server errors. Une petite horloge s'affiche en face de l'inventaire de mon PC. Rien ne se passe à la suite de cela.

Une idée de ce problème ?

Merci par avance de votre aide.
Avatar de l’utilisateur
agauvrit
Expert WAPT
Messages : 219
Inscription : 17 nov. 2016 - 10:25
Localisation : Nantes
Contact :

16 janv. 2019 - 13:56

Bonjour

Il y'a 99% de chances que vos postes ne soient pas à l'heure et donc non connectés correctement avec le serveur WAPT

Alexandre
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

17 janv. 2019 - 08:15

Bonjour,

Merci de cette réponse, mais les PC sont synchro sur le serveur, ils sont donc tous à l'heure. Ce matin je viens de voir qu'il s'est connecté lors de mon login à 7h46.

Je n'avais aucun problème avec la version 1.3

Je vais testé les postes en Windows 7 et vous tiens au courant.

Cordialement
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

18 janv. 2019 - 15:53

Bonjour,

Je viens de faire un test avec un poste en Windows 7 sur lequel la version 1.3 fonctionnait très bien. J'obtiens le même résultat. Donc, il y a un couac général quelque part.

Une idée ?

Merci d'avance.

Cordialement
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 772
Inscription : 10 juil. 2014 - 23:52
Contact :

19 janv. 2019 - 16:22

Entre la version 1.3 et 1.5< il y a d'énorme différence.

Comment avez-vous effectué la mise à jour 1.3 --> 1.5 ? a minima? avez vous bien régénérez des clé ?

On rencontre principalement ce genre de problème quand 'la requette est mal signée

Les raison du refus les plus fréquentes :
- Mauvaise clé
- Décalage horaire entre le poste qui a la console (celui qui a signé l'action) et le poste distant (5 minutes max de décalage)

si c'est toujours pas ça, démarrez le service sur la machine distante avec :

Code : Tout sélectionner

C:\Program Files (x86)\wapt\runwaptservice.bat -ldebug
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

21 janv. 2019 - 16:28

Bonjour,

La mise à jour ne se faisait pas. Donc, j'ai désinstallé la version 1.3 et installer la version 1.6, comme indiqué plus haut.

J'ai repris le certificat existant, c'est peut-être là que ça coince alors.

Comment dois-je faire pour faire un bon certificat ? Supprimer les anciens je suppose et en refaire de nouveaux ??
Par contre, il me faudra refaire les paquages que j'ai créé avec l'ancien certificat pour qu'ils soient resignés par le nouveau ?

Une question également, il me demande la vérification de la clé lorsque je mets à jour une machine, est-ce possible de faire en sorte qu'il ne demande plus cette vérification.
Ha oui, dois-je remettre l'agent à jour sur les postes après avoir refait les certificats ?

Merci de votre aide.
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

22 janv. 2019 - 08:05

Bonjour,

J'ai dû faire une réinstallation complète, car de 1.3 vers 1.6 je ne pouvais finaliser, problème de version d'agent, même après une mise à jour vers 1.6 ça ne fonctionnait pas, je n'avais pas trouver de réponses concrète sur ce soucis.

Je vais donc repartir à la configuration du certificat et resigner les packages.

Je vous tiens au courant. Merci beaucoup.

Cordialement
Tombru
Messages : 6
Inscription : 15 janv. 2019 - 14:22

22 janv. 2019 - 12:29

Bonjour,

Je viens de refaire la démarche, certificats, resigner les packages, mises à jour de l'agent.

J'ai testé sur mon PC Windows 10 et un Windows 7 de mon parc après la mise à jour de l'agent, ça fonctionne.
Sur un portable Windows 10 nouvellement installé, ça fonctionne également.

Je suis en train de déployer en conséquence l'agent à jour et fonctionnel sur l'ensemble de mon parc.

Le ticket est donc résolu.

Merci beaucoup à l'équipe pour l'aide apporté avec succès.

Cordialement
Répondre