Contactez nous

Pb d'executables WAPT après mise à jour 1.5.1.26 vers 1.6

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum

* Questions can be asked in English or in French. If the thread is started in English, stick to English, if it is started in French, stick to French.
* Vous pouvez poser vos questions en Français ou en Anglais. Si un sujet est commencé en français, merci de répondre en français. Si un sujet est commencé en anglais, merci de répondre en anglais.

Bonjour,
je viens de mettre à jour mon serveur wapt 1.5.1.26 (Debian) vers la version 1.6. Cette dernière version est bien indiquée sur la page web du serveur, mais l'exécutable que j'y télécharge waptserver-tis.exe est encore en version 1.5.1.26, et peut-être aussi le wapt-deploy ?

Image
je viens de me dépanner en téléchargeant manuellement les exes ici : https://wapt.tranquil.it/wapt/
Mais d'où peut venir ce souci de mise à jour ?
Il me manque quand même le waptagent.exe sur mon serveur. Même si le paquet waptupgrade installe bien la version 1.6, j'aimerais pouvoir l'installer manuellement.
Bonjour Gaelds,
gaelds a écrit :
23 octobre 2018, 10:51
Il me manque quand même le waptagent.exe sur mon serveur. Même si le paquet waptupgrade installe bien la version 1.6, j'aimerais pouvoir l'installer manuellement.
Le fichier waptagent.exe est recréé en même temps que le paquet xyz-waptupgrade. Il devrait être à jour.

Il y avait un vieux bug il y a longtemps avec les symlinks dans le répertoire WAPT. Est ce que vous pourriez vérifier dans le répertoire /var/www/wapt ou /var/www/html/wapt si il y a pas un lien symbolique entre waptagent.exe et tis-waptsetup.exe ou autre.

Cordialement,

Denis
Si j'utilise bien la commande correcte sous linux, il n'y aurait pas de lien symbolique dans ces répertoires:
root@srv-wapt:/var/www/wapt# find /var/www/wapt -type l
root@srv-wapt:/var/www/wapt# find /var/www/html/wapt -type l
root@srv-wapt:/var/www/wapt# find . -type l
root@srv-wapt:/var/www/wapt#
je ne sais pas si le waptdeploy.exe que j'avais repris sur https://wapt.tranquil.it/wapt/ est le bon ? Deux tiers de nos postes du domaine ont été mis à jour en 1.6.2.7 mais il en reste une vingtaine qui sont restés en 1.5.1 alors que la tache planifiée a bien été créée par le paquet waptupgrade et que la GPO se lance à chaque démarrage.
Si on exécute le waptdeploy manuellement il y une erreur ?
Sur un PC win10 bloqué en version 1.5.1.26, j'ai tenté la commande suivante :

Code : Tout sélectionner

waptdeploy.exe --hash=2be31296ac8520884705df44d1caaee97532e617b6c913baa699f3fabf7c4da1 --minversion=1.6.2.7 --wait=15
qui m'a rendu ça :
WAPT version: 1.6.2.7
WAPT required version: 1.6.2.7
Nothing to do
Update host status on the server
Depuis la console, le paquet 1.6.2.7 semble installé sur le poste avec le log suivant :
Setting up upgrade from wapt version 1.5.1.26 to 1.6.2.7. waptagent install planned for Mon Nov 05 19:05:55 2018
waptexit is running, scheduling a one time task at system startup with command c:\windows\temp\waptdeploy.exe --hash=870171eb0428a1fd14fcf7bde530f416f05c2bdb7cd178ef4c495afa3643ca98 --waptsetupurl=c:\windows\temp\waptagent.exe --wait=15 --temporary --force --minversion=1.6.2.7
Information : la tâche planifiée "fullwaptupgrade" sera créée sous le nom d'utilisateur
("AUTORITE NT\SYSTEM").
Opération réussie : la tâche planifiée "fullwaptupgrade" a été créée.

Et pas de trace de la tâche dans le planificateur.


Sinon sur 2 portables windows 7 64bits, j'ai trouvé la tâche dans le planificateur mais elle avait été exécuté sans succès. "Erreur de contrainte dans la définition de la tâche", d'après les contraintes de la tâche je suppose que le PC n'était pas sur le secteur au moment où elle s'est lancée ? Et ensuite elle ne s'est plus relancée ?


Et j'ai aussi vu un message trend micro au démarrage d'un PC, pendant l’exécution automatique du waptdeploy. Officescan avait bloqué l'installation depuis un répertoire temporaire. Je n'ai jamais trouvé la bonne façon d'exclure waptagent sur le serveur Trend, quand j'installe manuellement l'agent, je dois décharger officescan avant de commencer.
"Erreur de contrainte dans la définition de la tâche"
Il faut voir les paramètre de la tache (peu être que l'on installe pas si le poste est sur batterie)
Oui c'est bien une des contraintes qui était cochée, mais la tâche est censée se relancer au prochain démarrage sur secteur ?